Best answer

Field from Google Docs template doesn't show up in zapier

  • 2 August 2022
  • 3 replies

I’m trying to use Zapier to create a document from a Google Docs template with records from airtable but there’s one particular field that won’t show up.

Initially, the template was not set correctly (ie in google docs, this one particular field was in single curly brackets {field_name} when it should have been {{field_name}}). I’ve fixed the template since then and refreshed the fields and it still won’t show up. Other than that, I’ve deleted the action step and loaded the template again, I’ve made a completely different Zap from scratch and added the trigger and action step again and I’ve pulled in different test records. However, the problem still remains the same, this one particular field from the google docs template won’t show up in Zapier so I can’t fill it in. All the other fields from the template show up every time. 

Is there any particular reason why this is happening? Is it a problem with google docs or zapier? Are there any steps or things I can try to troubleshoot the problem? Any suggestions would help. Thanks!


Best answer by EJR 8 August 2022, 03:19

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +12

Hi @joseph_witzel!

I’m sorry that you’re having trouble with that field in your Google Docs template! Are there any spaces or special characters (eg punctuation) in the field name? That’s a common reason for template fields not working. 

This guide has some other troubleshooting tips, so you can take a look at those.  If you’ve tried them and are still having trouble, let us know!

Hi there, 

There are no spaces or special characters in the field name. I have also already tried everything in the guide that you have linked before, the problem still persists. 

Badge +3

Hi @joseph_witzel,

So sorry to hear that you are still having the same issue. 

I did some more digging and it appears there's a difference between a Google Docs Template (GTD) and a Template in Google Docs (TGD). If the document is an actual Template—and thus lives under the Template Gallery in Google Docs, this is not something we can pull in the editor.

The fix is to create a document in Google Docs like your copy (and not a template) and use that as to make a template—without it actually being a GDT.

When you get a chance, can you give this a shot and let me know how it goes?
Looking forward to hearing from you again soon!