Best answer

Failed to fetch a new appointment from Setmore Appointments: Error while retrieving: Cannot read property 'address' of undefined

  • 21 February 2023
  • 8 replies

Userlevel 1

I’m trying to create a Zap that pushes new Setmore appointments to a CRM. Our company has multiple locations and I have used this Zap successfully for others, but this one gives me an error every time I try to test the trigger and says it can’t find any new appointments, even though there are some. The only difference I can see is that this particular location has multiple staff members where other’s do not. This is the error that it’s giving me:

Failed to fetch a new appointment from Setmore Appointments

Error while retrieving: Cannot read property 'address' of undefined




Best answer by ken.a 11 April 2023, 21:16

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @znjones 

Good question.

Can you post a screenshot with how the Zap step is configured in order for us to have more context?

Userlevel 1

@Troy Tessalone Thanks! I assume this is what you were asking for. Let me know if there is something else.

Userlevel 7
Badge +14


Try checking the Setmore Zap app connection here:


If you still need help you can try opening a ticket with Zapier Support for further help:

Hello, could you help troubleshoot the issue? I'm encountering the same error and I'm not able to resolve it on my own. Would you be able to assist us with this?

Userlevel 7
Badge +6

Hey there @TBD Health,

Welcome to the Community! 🎉

The error you’re seeing appears to be a bug with the Setmore Appointments integration. Our team is aware of the issue and we're working with Setmore Appointments on a fix. I've added your email address as another affected user. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

Thanks! 😊

Userlevel 1

@TBD Health I am attempting a workaround using the Zapier email parser. Since the Setmore email notifications are always formatted the same way, we can extract all of the appointment data and send wherever we need. We’ve had a few additional errors with Setmore’s integration like addresses not being pushed through, so it’s looking like this might be the best bandaid until they can fix the integration.


Here’s a link to the parser:

You can create a new “Mailbox” and then add that new email address as the CC email in your Setmore account.

Userlevel 1

@TBD Health Interesting… One step I forgot to mention was mapping the data within the parser. You can highlight specific elements of the email and label them. Then those elements will show up as fields in a zap. Here’s a screenshot of how I highlighted the elements (I hid some the data which is why some areas look blank):

After you apply a highlight it will ask you to name that field. You may need to wait until another email get’s parsed, but the data you want should show up in the zap under the label names you create. It has been working for me so far, but I’ve only been testing it with a test Setmore account.

I haven’t tried this, but considered it before I did the parser. If Setmore is 2-way syncing with Google Calendar you could also potentially create a Zap that triggers when a new calendar event is created that pulls appointment info in from the calendar event. 

Userlevel 4
Badge +6

Hi @TBD Health 

Please try this workaround that @znjones did.

Keep us posted!