'Expired' Notion connection

  • 28 September 2022
  • 5 replies

Impossible to connect NOTION on zapier in 90% of cases I have the same error: "Expired"
In the remaining 10% it works but I do not see all the databases of the team space that I selected …

And in real life I can hardly see myself uninstalling and reinstalling notion for my whole team …

Can you help me ?

5 replies

Userlevel 7
Badge +12

Hi @JusteT44, welcome to the community :) 

If you can see a message saying that an account is expired, you can reconnect it by clicking on the link you see next to the error message or on the My Apps page.


Sometimes apps require you to re-authenticate after a certain period of time, or you’ll often be asked to re-connect your app if there’s a been a password change for that app. 


In terms of seeing databases in your team, you can only see a database after it has been shared with the bot that you have to create in Notion when you connect it to Zapier. Your colleagues wont need to uninstall and re-install Notion, but they will need to make sure that any databases you need access to are shared with the bot. 


Could you give that a go and let us know how you get on? Thanks!

Hey Danvers, Thank you for the welcoming !

I tried to relaunch my Zap connection and here is what it gives:
The Loader remains stuck a good time, then I have this message




and just for a complete information : 

My Team Workspace Notion

The database: "Candit. Sponta" is missing on zapier

Userlevel 4
Badge +6

Hi @JusteT44, for authentication help, I’d recommend reaching out to our Support Team , as I believe they have the expertise to assist. Typically, reconnecting accounts fixes all authentication issues. However, since that did not work for your account, Support should be able to take a deeper dive and help you out! 😄



This is a major problem, maybe it will be fixed in the next update.