Best answer

Errors with Discord and Ghost/Stripe {"user_id": ["Value \ is not snowflake."]}

  • 29 July 2021
  • 2 replies

I am trying to setup two things:

  1. When a user signs up on ghost - send them a discord invite
  2. If a user successfully subscripes and the stripe transaction goes through, add a role to them (I have a VIP role for paying members)

I have tried this with both Ghost and Stripe, so I think it’s a discord error. But I get the error

“Unable to load choices
We’re having trouble loading 'User' data (Cannot read property 'username' of undefined)”

On the action setting of the flow. So I tried instead of clicking “Users” clicking “Custom” and selecting “customer email” from the stripe side (thinking it would pass it through as a value) and I get the following:


{"user_id": ["Value \"\" is not snowflake."]}

This post has been edited by a moderator to remove sensitive information. Please remember to obfuscate any personally identifiable information prior to posting as this is a public forum. 


Any ideas on why this is incorrect? I gave discord all permissions when I connected it, but it looks like it can’t access what it needs to.




Best answer by SamB 25 January 2022, 15:01

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +11

Hey @gjmcclintock,

It looks like you’re running into the same bug as discussed here: 


I’ve added you to the list of users affected by this. I don’t have an ETA as to when it will be resolved, but we’ll be sure to contact you by email as soon as it is!

With the second error you’re seeing with the custom value option, it seems like that an email address was used instead of the user’s ID. If you’re able to get the Discord username for the user from Ghost/Stripe then you could try adding a Discord Find User search action to search for the relevant user ID.

That will take the username of the person and return their User ID, which you’d then be able to select in the User field instead of that email address. And that should get rid of that second error. :)

Userlevel 7
Badge +11

Hey @gjmcclintock!

You’ve probably already seen the email notification that was sent last week, but I wanted to confirm that this issue is now closed. So that error should no longer be affecting your Zaps! :)

Thanks for your patience while this issue was being worked on. If you’re still having trouble with this error please do contact our Support team. They’ll be happy to take a closer look and assist further!