Question

Error when trying to connect Wave account: Invalid request, no available businesses for this user.

  • 22 June 2023
  • 9 replies
  • 311 views

I’m receiving the below error when trying to connect my Wave account to Zapier. 

  • I have tried the instructions on this page, and this page. 
  • I have tried connecting from the integrations page on Wave.
  • I have tried connecting from creating a new zap, and the pre-made zaps. 
  • I have tried connecting from the connect an app page.
  • I am logged in to both Wave and Zapier.

I have tried to search for this error, but haven’t found any information or help. 

I have tried clearing my cache, restarting my browser (Chrome) and my computer.

I’m at a loss.

 


9 replies

Userlevel 7
Badge +9

Hey there, @nncydrw! Thanks for reaching out in community - sorry to hear you’re running into this.

Hmm, you may have already tried this but sometimes using an incognito browser does the trick?

If that doesn’t work, their documentation doesn’t mention permissions but may be worth double checking what kind this specific login has. In most cases you’ll need some type of admin/owner permissions 

And while I know this may seem tedious, I might even recommend confirming the logins match up. For example if you use, single sign-on (SSO) like Google or if you created a login and password, making sure those are the same on both apps. The reason I mention is it looks like it’s fairly easy to accidentally create a duplicate account

I hope some of this helps and please keep us in the loop!

@christina.d Thanks for the help! None of these things worked, though. 😕

This is the exact same issue happening to me. Given the timing of the issue, there may be some type of system error :/ 

Userlevel 1

I’m actually having the same  issue when trying to complete the  “Connect Wave Account” step from GSheets after installing the extensions…so it’s likely not Napier specific...

I thought the problem was either that Google was confused about which Google ID I was signed in as (I have several) or that Wave was confused because I had signed in over there with email/password instead of Google ID. I tested both of these theories and neither fixed anything…

I’m suspecting a recent change on the Wave side, given 4 posts here in the last 24h….and that GSheets and Zapier are affected.

@sheaone Wow thank you! When I initially googled this yesterday, I couldn’t find anyone else with this issue. Even if it’s annoying, at least I’m not the only one having a hard time with this :) Hopefully it’ll be fixed soon.

Userlevel 1

I am having the same issue. When logging in incognito, I did at least get an opportunity to try logging into WAVE but then I still got the error message. I also tried logging out of all google accounts and then logging back in with my account but no go. 

Userlevel 7
Badge +9

Yikes - so sorry to hear ya’ll are running into this but appreciate ya’ll flagging it here.

It definitely sounds like this may be a bug with the Wave auth process. While I don’t have an open report for it at the moment, I’ll definitely get ya’ll added if the team opens one up.

In the meantime, in the interest of full transparency, this app is owned and maintained by the team at Wave. If you haven’t already it may be worth reaching out to them directly to see if they have any insight to provide. Sometimes it helps hearing the feedback directly from their users. If you do hear anything before we do, definitely feel free to share it here!

Thanks friends and we’ll be sure to share an update if we hear more on our end.

Just an update - I couldn’t find a link or email for Wave’s support team, so I sent an email to sales hoping i could get a contact for support. If anyone knows who I can reach out to, please let me know!

 

I’ll keep updating this thread when I get more information. 

Userlevel 7
Badge +6

Hello everyone!

Just popping in with a quick update for you all. I've been seeing similar reports about this error, and although there aren't any open bug reports yet, it's making me think we might be dealing with a bug in the Wave integration.

The most effective next step would be to reach out to Wave support or send an email to our Support team, who can help create a bug report on your behalf.

You can report a bug to the Wave API team at this link: Wave API Support

Alternatively, you can reach out to our Support team here: Zapier Support

Hopefully, this helps! 😊

 

Reply