Question

Error in Update individual account: Failed to create an account in Neon CRM. The app returned “404”

  • 12 January 2023
  • 7 replies
  • 36 views

Userlevel 1

Hi,

After Running the zap to update the account in neon CRM. We are able to fetch the data from NeonCRM and Map the fields to the respected columns in “Setup Actions”, However in “Test Action” the account is restricted to update the account and throwing 404 error. We cross checked that we are passing all required fields in correct format. But still getting error as “Failed to create an account in Neon CRM. The app returned “404” ”,  Could anyone please suggest what’s wrong here.

 

Note : We are updating the account in Neon CRM , but still getting error as “Failed to create an account in Neon CRM. The app returned “404””. We are not creating , we are updating the account


7 replies

Userlevel 1

Hey @SamB , 

Thank you for your quick response!

As per your suggestion we have raised the issue to Support Team.

 

Userlevel 7
Badge +9

Hey there, @Mary Britto!

I can see you were able to open a ticket with my teammates in support, which is amazing. They did share tip and I wanted to check if it got ya on the right track?

It seems like the error is happening because there are no account custom fields specified in your CRM currently. Can you please try creating one in the CRM first under Settings -> Global settings -> Account Custom Fields and re-running the test action step for the Update Individual Account in NeonCRM action step?

We’d recommend continuing the troubleshooting process with my teammates in support if you’re still seeing hitting the 404 error. Please keep us in the loop with any solutions ya’ll arrive at! 

Userlevel 1

Hi @SamB ,

Thank you for the response!
The second Step in zapier is Find Account in Neon CRM (refer attachment 1). I was able to fetch the Account from Neon CRM with correct Account ID in step 2, and the *required field  Account ID is matched to existing Account ID in Neon CRM. 

We have confirmed that the Account ID in ZAP as well as in Neon CRM both are same and correct as required.
We are using Update Individual Account action in our zap as we want to update individual account in Neon CRM.

Userlevel 1

Hi @christina.d ,

Thank you for your quick response!

As per your suggestion we created account custom fields specified in CRM currently. We have created one in the CRM under Settings -> Global settings -> Account Custom Fields and re-running the test action step for the Update Individual Account in NeonCRM action step is not working as expected and again hitting the 404 error.

Userlevel 7
Badge +11

Glad to hear it @Mary Britto. Fingers crossed they’ll be able to help you get a solution here swiftly! 🤞

Userlevel 7
Badge +11

Sorry to hear you’re still running into that error here, @Mary Britto.

At this point I think it would be best to continue the conversation with our Support team. They’ll be better able to dig into the logs for the Zap to investigate further. It could be that this error is being caused by a bug, in which case they’ll be able to open up a bug report for that on your behalf. As ever, please do report back here to keep us updated on whether you’re able to get past that 404 error! 

Userlevel 7
Badge +11

Hi @Mary Britto

Hmm that’s strange. 404 type of errors are usually given when something can’t be found. It looks like the wording on that “Failed to create an account” error, is most likely a typo, otherwise it would have create a new account if it hadn’t found one instead of erroring. 

I took a quick look at the app’s fields and it seems that the Account ID field is a required field. I’m wondering if the Account ID being used doesn’t match an existing account’s ID number in Neon, which could explain why it’s giving that 404 error.

Could you take a look in your Zap and the account in Neon to confirm whether the Account ID number being used on that Update Company Account action is correct?

If it’s not correct, you may want to try adding a Find Account Neon CRM action to get the correct Account ID number, then use that ID number in the Update Company Account action instead. Please do let us know if that solves it. 🙂

Reply