Best answer

"Dev_Method" error from Jira Software Cloud

  • 22 February 2024
  • 30 replies
  • 358 views

Userlevel 2

 

Hey all,

 

Per the image above, the zap I have been using without issue since approx. May 2023 has just started kicking up this error. I haven’t changed and / or updated anything in that zap since that date, but just went back in and re-authorized my Jira connection, but still getting this.

 

The zap is a connection from Jira to Trello, which finds a card based on the summary field and updates certain line items if they do not match.

 

Any ideas? I did read that it could be due to Zapier updating and Jira (Atlassian) having not updated/upgraded their version of Zapier yet. Any help would be greatly appreciated!

icon

Best answer by SamB 7 March 2024, 20:07

View original

30 replies

Userlevel 7
Badge +11

Hey there @Crrip

I did some digging but couldn’t see any bug reports open for that exact error. However I did find a bug report regarding Jira Software Cloud app connections expiring too frequently so I wonder if perhaps the connection may have expired as the Zap was triggering and that caused the error. Do you think that might be the case?

To help determine that can you try replaying that run of the Zap and let me know whether that’s now able to run successfully? Note: if you are running into that bug then you may need to reconnect your Jira account again if it’s expired again and then try replaying it. 

Let me know how you get on with that and we’ll go from there! 🙂

Userlevel 1

Hey @SamB and @Crrip ,

 

We started to experience the same exact issue today.  I have confirmed that replaying the run results in the same error message. This integration was working as of yesterday without any changes to the Zap.  I have also confirmed in the editor that that I am able to test the connection without issue, refresh fields and execute the Zap successfully from Test.  We have multiple Zaps to Jira and they are all failing with the same error message.  

 

Any recommendations on how to address this would be greatly appreciated.  Thanks!

Userlevel 2

Hey @SamB and @Crrip ,

 

We started to experience the same exact issue today.  I have confirmed that replaying the run results in the same error message. This integration was working as of yesterday without any changes to the Zap.  I have also confirmed in the editor that that I am able to test the connection without issue, refresh fields and execute the Zap successfully from Test.  We have multiple Zaps to Jira and they are all failing with the same error message.  

 

Any recommendations on how to address this would be greatly appreciated.  Thanks!

+1 - Have re-connected to Jira, replayed the run, duplicated the Zap and still getting the same. Here’s hoping for a fix soon!

We have the same issue. Replaying does not do anything either. 

Userlevel 7
Badge +6

Hi @Crrip, @jsdayton, and @MarkosG,

I saw that one user was having the same issue before, but they said that the error disappeared and it started working again after they replayed the error run.

Could you please try these for me:

  1. Double checking all of the permissions for the relevant projects
  2. Reconnecting the Jira account in Zapier (to ensure there aren't any older settings cached)
  3. Replay the errored Zap runs: https://help.zapier.com/hc/en-us/articles/8496241726989-Replay-failed-Zap-runs#h_01HPFHBBK5R1RRS1QR885SQAKY

I'll be keeping an eye out for your response!

Just started happening on our Jira integration too...

We are seeing the exact same issue as first reported by Crrip. Please keep us in the loop on resolution.

having the same issue as of a few days ago.

Same issue over here. Testing Jira connection confirms it is connected and working. Turning zaps on and off and retesting them all still results in the same error message.

Userlevel 7
Badge +6

Hi friends,

I did some digging into this, and it seems like this is a bug with the Jira Software Cloud integration. Our team is aware of the issue and is working on a fix. I've added your email addresses as another affected members. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

I appreciate your patience and understanding.

Userlevel 1

Hello, just to report that we are also being affected by this. A zap that was working 100% since 2022 started to fail with this message. Is there any list to subscribe to be alerted when this is fixed?

Userlevel 2

Hello, just to report that we are also being affected by this. A zap that was working 100% since 2022 started to fail with this message. Is there any list to subscribe to be alerted when this is fixed?

Maybe @ken.a can add you to the notifying list when it’s fixed.

Same here - this is heavily impacting our business and ability to operate.
What is the current ETA for resolution?

Can I also be added to the relevant ticket, please?

 

Userlevel 1

This is a heavy impact to our business as well.  Escalation of this issue would be greatly appreciated. 

@ken.a you mentioned being added to the bug ticket , but I have not received a notification with a link to that ticket, can you please provide it here? 

Thanks!  

@ken.a We are having the same exact issue as well. Started 8 hours ago or so.

 

Please add us to the list to be notified when this is resolved.

Please add me to the list, I have the same bug.
Thank you.

 

@ken.a Same bug here for the past two days affecting a few zaps that have been in place for over a year. Would really appreciate being added to an email list or bug ticket too. Many thanks.

Hello @ken.a, i would like to ask you to add me to the mailing list since we are facing the same problems with one of our zap without anything changing on the zap itself. Rerunning and republishing didn’t changed anything.

The same situation is happening with us. This issue has escalated into a significant problem. We depend on numerous zaps to automate Jira issues, and they have ceased functioning for the past two days.

Hello, i have the same problem with a zap that was working perfectly fine until this morning when this error popped up

Happening on our zaps too.  

Userlevel 1

@ken.a Do you have an update on the status of this issue?  This is continuing to have a business impact and I would like to avoid having to implement another option/solution.  Any update on current status or an ETA would be greatly appreciated.  Thanks! 

 

@ken.a We are also looking for an update to the status.  Can you include us in your communication for updates on this issue.  Thanks!

Hello this is affecting our bussiness too it started couple days ago

Hello!

Our Zaps are failing too. It’s impairing our business operations.

Please add me to the list and inform me when it’s resolved.

Reply