Best answer

Cannot create new Asana task with Personal plan

  • 17 February 2024
  • 14 replies


I have Zap that used to have a deprecated “Create Task in Asana” step. I went into the process of updating the Zap to use the non-deprecated version of that step.

Unfortunately, now the Zap does not work any more as I get the following error when I test it:

Failed to create a task in Asana

The app returned "Custom Field Settings are not available for free users.".


I am using the Asana Personal plan, so it’s normal that I cannot use custom fields. However, I haven’t set anything in the step to create custom fields.

When setting up the step, I do get that information message:

Custom Fields - If you are on a paid Asana plan with access to their custom fields, when you select a project above, the custom fields for that project will be displayed.


So, I understand that as I’m on the free Personal plan of Asana, I should not even be able to set up anything related to custom fields.

I tried turning the Zap off and on, and also to completely remove the step and create it again, but neither of those helped.

This is quite annoying as I used to have a working Zap, and by trying to use a non-deprecated step, I’m now stuck with a non-working Zap 😕

Thank you in advance!


Best answer by ken.a 26 February 2024, 10:17

View original

14 replies

Userlevel 7
Badge +14

Hi @tchoukball 

For us to have full context, we would need to see screenshots with how your Zap steps are outlined and configured along with the encountered step error.





Hi @Troy Tessalone,

Thanks for your reply. Here are the screenshots. I think I covered everything, but please let me know if I missed something or if you need anything else.


Either I missed it, or it didn’t upload. Here’s the Action section of the Asana step:



Userlevel 7
Badge +14


Try changing this to: +7d


@Troy Tessalone Thank you for the suggestion. I tried, but unfortunately, it didn’t change anything. Here’s a screenshot of the submitted fields. After that, I get the same error as before.



i’m having the same issue too

Userlevel 7
Badge +14

@tchoukball and @dr_bbbb 

Might be worth trying to open a ticket with Zapier Support:

I have this same problem too. I tried using a free account (that was never on premium), but i encounter the same problem

I tried using a free account (that was never on premium), but i encounter the same problem. Also tried using another employee’s account but didn’t work.

The workaround i have used:
1. Create a “template” task in the project you are working with
2. Use the zapier-asana action “duplicate a task”
3. Use action “update a task”, search the new task ID

@tchoukball you could try this in the meantime, while zapier looks into the issue

I am experiencing the same issue. I hope a solution is found soon.




+1 for this. I’m experiencing the same issue, even though I’m not applying any “custom field settings” to my zap.

Userlevel 7
Badge +6

Hi friends,

I did a quick check on our bug reports, and it seems like the error of "Custom Field Settings are not available for free users." has been fixed.

Could you please confirm if you’re still running into the same issue here?

I'll be keeping an eye out for your response!

@ken.a Confirmed… It’s working now! Thanks for fixing this.

Userlevel 7
Badge +6

That’s an amazing news @Aponte! We’re glad to hear that the issue is now resolved.

Happy Zapping! ⚡️