Best answer

API Key Missing Error with Formidable Forms and Wordpress

  • 25 July 2022
  • 2 replies
  • 299 views

I have previously used Formidable with no issues on Zapier. When I was recently trying to edit the forms, I found that they were not pulling the most recent changes in Formidable. So I did a basic reconnect, and it was still not working. I then flushed cache on Wordpress, disconnected Formidable from Zapier, and attempted to re-connect it.

When I attempted the reconnect, I began getting the API error code issue. I then went through ALL of the troubleshooting options advised at the Zapier/Formidable troubleshooting page suggested, with the same results.

My host runs NGINX servers, and that Basic Authenticate is on by default in Privacy Mode, although I'm not sure what that entails, so I have opened a ticket with them to describe that in more detail. On NGINX servers there is no .htaccess that can be edited, but that is the only option I'm unable to troubleshoot based on the instructions that could be an issue - however there was no issue previously until I attempted the disconnect/reconnect.

I have also removed the Formidable plugin (including the Zapier plugin for Formidable) and re-installed them, generated a new API key and it did not work. I eliminated every plugin that was not necessary to the site and I’m not running anything that isn’t core to WP or my website builder. When I attempted the Postman troubleshoot, it did not work, and just I tried using the API key at the end of the trailing url - at that point I started getting a 404 error, but I'm not sure where to go from there, as there is no documentation.

Again, the connections were working fine before I started doing edits and attempted a re-connect, so it was working with my host. I have not made any other changes, added any plugins or done anything in Wordpress that would have affected Zapier or Formidable.

Any help would be appreciated!
 

 

icon

Best answer by jesse 25 July 2022, 22:10

View original

2 replies

Userlevel 7
Badge +9

Hey @AustinJames! It looks like you were recently in touch with our support team regarding this issue and they have identified this 404 connection error as a bug. They’ve added you onto our list of affected users so you’re notified when things get resolved. We’ll also update this thread with the resolution and any updates along the way.

I see they shared some additional advice for trying to resolve this faster, which I will paste here for anyone else experiencing the same issue:

Could you reach out to their support and see if you're able to get a resolution/resolve through that channel as well? Should you learn something along the way, please let us know so we can also update the bug report and our internal notes for other affected users—that would be massively appreciated.
 
You can open a ticket with them here: https://formidableforms.com/new-topic/

Hi I’m facing the same issue 

Reply