Best answer

Airtable: "Record could not be created because the underlying table is externally synced"

  • 5 April 2023
  • 3 replies

Userlevel 1

I’m getting the above error. The destination table in Airtable is indeed externally synced—I have it embedded into a site. But that seems irrelevant? External syncing does not impact the data in the destination table. Is there a way around this error?


Best answer by zmRI 7 April 2023, 19:45

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +6

Hey there @zmRI,

Welcome to the Community! 🎉

I did some digging into our notes, and it seems like this error can be a bit of a red herring. While it can be due to the table being externally synced, it can also be due to a change in a synced table not recognized by the Zap. Here is what another customer had found after reaching out to Airtable:


The primary key of a record in a synchronized Airtable table was updated to a new name. The source system didn't know about this update and sent the old name. What should have happened is that the primary key matched and linked the record. Instead, we got this error about the external sync.


I hope this points you in the right direction. Could you attempt recreating a fresh Airtable connection (including clearing the table and base selections in the affected Zap) and resetting the Zap up?

Userlevel 1

Thanks so much for the quick reply, it took me a bit to get back to this problem.

So I tried creating a new Airtable connection and rebuilding the Zap from scratch—and that did not work. However, I realized that there’s another way to interpret “external sync”: as fields within my output Zap that are linked fields dependent on external Airtable bases. (For example, I was outputting a ‘First Name, Last Name’ into an Airtable field that was synced in internally from another of my Airtable bases, titled “People”.) 


Once removing those two fields from my output (a Contact field and a Location field), the Zap worked correctly. It’s unfortunate that I will have to enter the contact and location manually (by picking them from my linked list from another Base), but overall it’s not that big of a deal.


Tl;dr: Apparently zapier cannot zap data into linked fields WHEN those fields/columns originate, at root, from other Airtable bases than the one being zapped into.


Hopefully this helps other folks in the future! Thanks so much.

Userlevel 7
Badge +6

Hi @zmRI,

Awesome to hear that you were able to sort it out! Thank you so much for sharing how you resolved the issue - that will be really helpful for other members of our Community.

If you have any other questions, please feel free to post them in the Community. We are always happy to help! 😊