The Jotform Submission ID field is not integrating properly in the Excel sheet

  • 15 December 2022
  • 4 replies

Hi - New to Zapier. 

I have used zapier for Jotform and Excel integration. All Jotform submissions are recording nicely into the excel spreadsheet. Each new one appearing on a separate row.

However, the Submission ID field is not integrating properly in the excel sheet .Originally it shows up in the field as 5.46872E+18. I’ve amended the formatting for that column to allow for numbers etc and then it shows majority of the Jotform submission ID however makes the last 4 digits as zeros, when there are actual numbers in the orginal jotform submission ID. For example, the Jotform ID may be 5468729065987856 and when it integrates into excel via zapier, the number is 5468729065980000.

I’ve tried amending the excel column to a number, general, text etc and even added a ‘ to the beginning and it doesn’t work.

There are only two ‘ID’ fields to choose from in Jotform to integrate into excel. One is ‘ID’ and the other is ‘Form ID’. I have tried both and the ‘ID’ field is the only one that at least has some of the correct numbers in it when it transfers over. 

Can anyone suggest how to fix this??

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @RistaKCS 

Good question.

I’d recommend using Airtable instead of Excel.

Airtable has Field types. (e.g. Single Text)

Userlevel 7
Badge +12

Hi @RistaKCS!

I’m sorry that you’re having trouble getting Excel to keep the format that you set. Looking at the format in Excel would definitely be my first shout, and I can see that you’ve already tried that. Just to confirm the settings that you need, you’ll need to select the whole column where the ID is going (not just one cell) and choose Text for the format (not number or general). Could you give that one more try to check that the settings don’t stick?

Let us know how you get on!

Just wondering if this issue was ever resolved? I’m having the same issue at the moment and it’s very frustrating 😤

Hi all, 

The issue seems to be related to Excel’s Number format. When the format is not compatible with Jotform Submission ID, it gets only a portion of the Submission ID. If the actual ID was 5468729065987856, Excel records only a part of the ID: 546872906598So even after the cell format is changed, the original data cannot be extracted. Excel displays the number as 5468729065980000.

But if the column type is set before the zap runs to something that may hold the Submission ID like “text”, the Submission ID can be viewed without any problem.