Best answer

Need assistance with Email not displaying active link using Printful Zap

  • 2 October 2020
  • 5 replies
  • 303 views

Userlevel 1

Hi everyone!

 

So, I have done some email testing using the Printful Zap.  Whenever an order is shipped out for a customer, an email is sent to that customer using the Zap.

Overall, the email sends out just fine.  However, there is a tracking URL that allows the customer to track the shipping information. It also displays, but it is not displayed as an active link.

I have tried placing <a href => </a> tags around parts of the area that needs to have a link, but it is not working.

Any ideas on how to get the link to display correctly? Screenshots are below.

 

Here is the Zap email layout I am working with:

 

Here is that same part of the email when received by the customer:

 

Thanks everyone!

icon

Best answer by steph.n 6 October 2020, 04:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +8

Hi all, posting the solution that Clint sent to @mikeinsc here for anyone else looking for it:


Thanks for writing in! I'd be happy to take a look at this Zap and get it figured out with you.

I took a look at your examples and as far as I can tell, number 6 would be the one that should work. I ran it in an HTML tester and it did create the proper links, so I'm not sure why that text isn't a hyperlink at all. Most of those examples should at least produce a broken link.

Since this is formatted properly in Zapier, here are my two guesses as to what's going on:

1. Hotmail is stripping the links out of the emails. This could be an anti-phishing thing, trying to prevent fraudulent emails from being sent to customers
2. Your SMTP server is stripping the links out of the emails. I'm not sure what the reason would be here, honestly, since you own it.

I think the most likely option is number 1. Hotmail might detect that kind of link as often fraudulent, and is simply stripping it out without telling you. I think the best way of testing this would be to send the email to a different provider.

To that end, would you mind trying to send it to me? You could just type in my email (xxxxxx@zapier.com) into the email field for testing, and send one my way. Let me know if you do that, and I'll take a look at what I receive. I would recommend getting rid of all the links except for number 6, since that is the one in the format that should work, and that way we avoid any conflicting HTML.

Thank you!

Userlevel 7
Badge +14

Structure the HTML as such:

<a href=”[TRACKING_LINK]”>[TRACKING_LINK]</a>

 

NOTE: Most email services providers will convert a link to be clickable.

Userlevel 1

Thanks for the reply, Troy.  

I tried your idea, yet I am still unable to get the active clickable links to display.  I even adjusted the code several times, just to see if a different variation might help.

 

Also, if it helps:

 - I am altering the code within the the HTML Body section, of the Zap Edit email functionality. 

 - Additionally, I am using an SMTP server from my website, to send the email.

 - Lastly, I am send the email to a MS Hotmail/Outlook account. I would think that MS Hotmail/Outlook would display emails formatted for html, not plain text.  That’s been my experience when getting email in the past.

 

Here are some screenshots of  what I tried. You will notice that there are slight deviations in the html code changes. I labeled each test 1-6.

The HTML Body

 

The Output in the email it itself.

 

Thank you for your assistance.

Userlevel 7
Badge +14

This is the proper HTML formatting that will produce a clickable link. 

HTML documentation: https://www.w3schools.com/html/html_links.asp

Perhaps the sending settings for the email are set to plain text instead of HTML.

 

 

Userlevel 1

Thanks for the follow up, Troy.  Still not getting the desired results.  There is probably something in the setup that I am missing.  I have sent the Zapier helpdesk an email, so hopefully I will be able to get some traction on the issue.

Again, thanks so much for your input.