Internal Server Error - WordPress connection

  • 27 June 2021
  • 1 reply


I have a zap from Airtable (new row) > WordPress (new post).

Normally, everything works fine, but now I’m getting an error on some of the new rows (the one where I copy-pasted some text).

The error I get is: There is an error with WordPress: The app returned “Internal Server Error”.

I also tried the zap with copy-pasting the text to Excel and creating a zap from Excel (new row) to Wordpress (new post). I get the same result with the same items.

How can I solve this or what am I doing wrong that I always get that error with those rows?

Thanks in advance!

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +14

Hi @BeeMate 

500 Internal Server Error or other trouble connecting.

In order to connect to WordPress, you must have XML-RPC functionality turned on. This is turned on by default in WordPress 3.5+. If you're having issues connecting, go to Settings > Writing > Remote Publishing and check the checkbox.

You may also receive this error if your WordPress installation is secured and not publicly available. Unfortunately, the installation must be publicly accessible to work with Zapier.

Also, we're unable to provide IPs to allowlist as our IPs are not static - they rotate because we use AWS. If you'd like, you should be able to allowlist a block of IPs from AWS to make this work. You would just need to make sure the list you're allowing is the us-east-1 IP range.

AWS provides a list of their IP address ranges at You can read more about how to use those IPs here.

Additionally, Zapier's calls will always include the header User-Agent: Zapier, so this may be an alternative when allowing a whole range of IPs isn't feasible.