Best answer

How to assign unique timestamp to each "STEP" of the Zap

  • 6 July 2021
  • 4 replies

Hello everyone,

I have a multistep zap in which  each step adds a new row to a Google Spreadsheet.

Each row must have a “UNIQUE” TIMESTAMP, which im not being able to work around.

I tried using =now() and {{zap_timestamp}} in the value for the TimeStamp, but every time the next step/row is created, the previous row TimeStamp is overiden by the TimeStamp of the present row.

Any ideas on how to avoid this?

Basically what Im looking for is a TimeStamp for each Step, not for the Zap.

I tried also delaying the steps but that dint work either.

Im trying to avoid having several zaps for the same task.


Thanks for reading!



Best answer by Troy Tessalone 6 July 2021, 17:50

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @Nicotlan 

Check out this article:

{{zap_meta_human_now}} will populate the the timestamp at the time the Zap step runs.


This timestamp will print the date and time in a format that apps (and APIs) can easily read. This command will always output an ISO-8601 timestamp in UTC time (for example, 2021-01-15T18:07:48+00:00).


This timestamp displays UNIX time. Some APIs might require a timestamp in this format instead.


Hi @Troy Tessalone , Thank you for your answer.

I have checked that article before and its not what Im looking for.


Im NOT trying to set a time stamp for the zap.

I am trying to set a timestamp for when the row is created.

i.e. in a multistep zap where each step creates a new row. Each row should have its own UNIQUE timestamp, but what its happening is that each new row TimeStamps, overrides the Time Stamp of the previous rows added. So i end up with a bunch of duplicate time stamps.


Userlevel 7
Badge +14


You can use the timestamps variables in the abovearticle to create a timestamp in a GSheet cell for a row, w/o using GSheet formulas.

Perhaps you can post screenshots of how your Zap steps are configured.

Also, may be helpful to outline a specific example where you are having issues.

Thank you @Troy Tessalone , actually i was missing in one of my steps I had =now() instead of {{zap_meta_utc_iso}}


I changed that, added a one minute delay between steps, and that seemed to work,