Best answer

Freshbooks Quantity and Line Total (Unit Amount?) are missing

  • 19 April 2020
  • 2 replies
  • 241 views

Hello,

I’m trying to setup Freshbooks New to create a new sales invoice into Xero when I generate the invoice in Freshbooks. However, the Xero zap is asking me to input the required field “Line Quantity,” but I can’t find any field that is being detected in my Freshbooks invoice even though Freshbooks clearly has Quantity and Line Total in their invoices. I tried fudging it by inputing “1” into the Line Quantity field in hopes that it will always default to saying 1, but it’s still not allowing it to work. Please help!

 

This is the exact error message I am receiving: 

“We had trouble sending your test through.

A validation exception occurred, The UnitAmount field is mandatory and cannot be derived from the Quantity and LineAmount fields., The LineAmount field is mandatory and cannot be derived from the Quantity and UnitAmount fields.”

icon

Best answer by steph.n 28 April 2020, 21:45

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +8

@joshjcurtis - Thanks for your patience. We understood that you went back to using Freshbooks. We just wanted to ensure others received the answer:
 

Both Line Quantity and Line Unit Price are required. We can see this in the full error provided by Xero:

https://cdn.zapier.com/storage/files/dc929293b6d3c965d452abc5a68a4dfd.txt

If a "Line Item Code" value is not provided, Xero requires that you provide both a price and a quantity. That way, it can calculate the total for the invoice. The "1.0" that has been manually entered in for "Quantity" should work, as soon as there is a "Price" associated with the line-item as well. That will allow Xero to multiply the two together to create a total price.

Once the action has a value for "Quantity" and "Unit Price", even if one or both of those values have been manually entered, the action should succeed.

Userlevel 7
Badge +8

Hi @joshjcurtis ,

Thank you for reaching out- so sorry you are running into this error!

I am escalating to Support as they can dig into your Zap and help to resolve most quickly. Sit tight and someone will be in touch just as soon as they can!