Best answer

Facebook pages error - Object does not exist

  • 18 March 2020
  • 9 replies

We are having this a similar issue. 



Best answer by Danvers 17 April 2020, 13:49

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

@npatel I’m sorry that you’re having trouble with your Zap - this doesn’t look the same as the original issue that was reported, with most users seeing the ‘Unsupported Get request’ error message. Is this a new Zap that you’ve made or an existing one that’s stopped working?

@Danvers I have had this Zap setup for at least a year now. I even tried creating a new Zap and would still get the error. I haven’t changed my password for Facebook or anything similar that would cause an error like this. I have another Facebook Page where the Zap is working perfectly fine. 

Any help would be much appreciated as I couldn’t find the error code anywhere else on the internet.

Thank you. 

Userlevel 7
Badge +12

 @npatel I’ve split your reply on the Facebook Pages Unsupported Get Request post here so that we can take a closer look. 


The first thing that I would do is to check the permissions for the FB page connected to the Zap that’s hitting an error. If the permissions are the same as a page which is in a working Zap, could you please send a screenshot of how the trigger is set up? That might give us some clues as to why you’re seeing this error. 


Here is the screen shot from the My Zaps page showing the connection is successful.

I have also attached screen shots of how the trigger is setup. 

Please let me know if this information is helpful, as I am currently lost on why we are still getting #33 error. 

Thank you. 





Userlevel 7
Badge +12

Thanks for sharing that screenshot @npatel. The fact that the you have other Zaps connected to different pages in the same account suggests that is is something specific to that page, and the most likely cause is permissions. 

I understand that you haven’t changed your password, but lots can happen on Facebook’s back end that can reset the permissions. 


Please could you go to the Business Settings in your Facebook pages account and  from there grant Zapier explicit access to the Pages you wish for us to use in Zap.

To do this, follow these steps. Click "View and Edit"



Then scroll to Manage Pages and select the Facebook Pages that you wish to use in Zapier followed by the "Save" button.


Finally, go back to your Connected Apps page and reconnect Facebook Pages again.


Could you please try that and see if that clears the error?

Hello @Danvers 


Please see the screenshots below. I went through and re-applied the settings and re-saved. 

I also went through and went to the connected apps page and got a Success! 

However, its is still throwing the #33 error. 


Thank you for all your assistance. 

Let me know if you have any other ideas. 




Hello @Danvers 


We have tried creating a completely new Zap, thinking there was an internal issue with the Zap we were trying to fix.

However, we were still received the #33 error on our end. 

Any suggestions would be greatly appreciated. 

Thank you. 

Hello @Danvers and Zapier Team! 

Our Zap in question was able to send a Successful Test this morning, however we are still having troubles.

We switch the Zap to the “On” position, but every time we come back to the page, or refresh the Zap is turned into the “Off” position :sweat: . I am not sure why it keeps switching off automatically. It is not giving us any feedback, or error messages at this point just turning off.


Also, as stated above we tried to recreate this Zap, and the same issue is happening (it turns off automatically).

I have Admin Access on our Facebook Pages. Please let us know if there is anything you find regarding permissions, or why the Zap is automatically turning itself Off.

Thank you! 



Userlevel 7
Badge +12

I’m sorry that you’re still having this trouble @npatel! I’m going to forward this to the support team so that they can take a closer look at your Zap to see if there are any errors in the logs. Someone will be touch via email to help you with it as soon as possible.

Userlevel 7
Badge +12

I wanted to follow up on this thread in case any one is having similar issues.


When using Facebook Pages, some users are seeing an error that says: “(#33) This object does not exist or does not support this action”


We’re looking into this error but don’t currently have an update on it.