“Authentication Failed” error when adding connection to Teachable

  • 23 December 2021
  • 10 replies

We have successfully added 6 connections before without issues.  Now it gives us an error message every time.  Checked with Teachable and we are using the right subdomain to make the connection.  Sent a request to Zapier, no reply.


Authentication Failed:

We don’t see any popups to “allow or “accept like it asks.  Where is this?  It’s not on the Teachable side.

I don’t see where there is a place in the account to correct permissions.


Any help would be great.  Oh, and have a great holiday!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

10 replies

Userlevel 7
Badge +14

Hi @Academy of Cleaning 

For your reply from Zapier Support, make sure to check your spam/junk and search your entire mailbox for “”.

Userlevel 7
Badge +14

@Academy of Cleaning 

Try using a new/different private browser to connect and authorize Teachable in Zapier here:

Userlevel 7
Badge +14

@Academy of Cleaning 

Teachable actions returning 401 - "You can't do that" error

There are two common reasons for this type of error:

Teachable plan type

  • Teachable triggers on Zapier are available on Teachable's Basic plan and up.
  • Teachable actions are only available on Teachable's Professional plan and up.

If the connected account is not on a Teachable Professional plan or up, the Zap will show a "401 - You can't do that" error when you try to use an action.

Teachable offers more details on the difference between plans.

The Teachable school name (subdomain) has changed

If you're on a Professional plan and still see a 401 error, check if the school name was changed after creating the Zap. Changing the school name causes the subdomain in Teachable to change.

To fix this, add a new connection for Teachable on Zapier.

We are on the Pro plan.  We even tried to set up the connection incognito. And the school name has not changed.


Userlevel 7
Badge +14

@Academy of Cleaning 

Probably best to open a ticket with Zapier Support here:

I did that two days ago.  Still nothing.

Userlevel 7
Badge +9

Thanks for reaching out, @Academy of Cleaning! I’m sorry to hear you’re running into this. We definitely want to help.

I did some digging and I can see you did reach out to our support team, which is perfect! That said, the ticket was opened under a different email address than what you registered under the community with.

The only reason I mention this is because my teammate Abraham responded yesterday a few hours after the ticket was opened. As Troy mentioned, sometimes spam filters reroute our emails to the junk folder so it may be worth taking a look there as well! 

One thing that might be useful to note is this particular app is managed by Teachable, not Zapier. When this has come up in the past their team has recommended users go through the reset password flow, which can be located here:


I hope this helps! 

I reached out to Teachable first, and they said that I was doing everything right, which is exactly what I’ve done to set up the 6 other campuses we have using Zaps.  Our IT guy got let go and I had to change not only the password, but my email.  So we got that covered too.


Yesterday, I checked all the other campuses and their connections are good, but this one for Dutch Hollow will not work.


I’m stuck here between the two platforms, doing everything you tell me and nothing seems to be working.

Well, I continued to work with it this morning and got it to finally work.  

Userlevel 7
Badge +11

Glad to hear you were able to get this solved, @Academy of Cleaning

Would you mind sharing how you resolved the issue? I’m sure there are many others in the Community who could benefit from your answer! :)