Best answer

What does it mean when I get a response 'key'?

  • 25 January 2023
  • 1 reply

I’m trying to implement dynamic fields into my action with responses from a trigger. So the flow is like the following:

field A → trigger loads field B → trigger loads dynamic fields.

However, when I test the action, I only get ‘key’ as a single response and I am unaware of where to begin debugging this. I saw only one previous post seemingly with the same error 

However there also doesn’t appear to be any resolution in that post.

I’d love any help from here. Also, what’s the best way to inspect what is Zapier trying to send to my server, this also does not seem very clear.

Thank you.


Best answer by kxzap 25 January 2023, 10:40

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Solved. After hours of debugging, I finally understood that the error message ‘key’ means that my dynamic fields generation included an empty object {}.

My dynamic fields generation looked like:


After removing the empty object, the flow worked. Would recommend the error message to be something similar to `key` not found in /FieldSchema to avoid next developer scratching their head wondering where to begin debugging.