Question

Trying to integrate our app and Zapier will not "post" data

  • 2 September 2023
  • 1 reply
  • 75 views

As a developer we have an app I am trying to setup for use on Zapier. Right now I am trying to create an action and gave Zapier our webhook URL as a POST request. I setup several fields and ran some tests. Zapier does not seem to create a valid POST request as there is no POST data being sent to our webhook URL. Attached are some screen shots. Any help would be much appreciated!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 2
Badge +1

Zapier does send post requests - I’ve made a few integrations with AI services using both code mode and the no-code form path. 

You might learn more about what is going on by investigating the HTTP and console tabs when you run your test. 

Another approach is to send your request to something like https://webhook.site to see what your other end would “hear” from Zapier. That can be handy when you don’t have access to the ingress logs of the other system. Sometimes it just jumps out at you, like say not marking it as JSON vs form encoding. 

Beyond generalities, I can’t really tell what is wrong based on the screenshots so far. My proposal: in lieu of posting more screenshots (thoug they would be welcome) a short loom/screensharing video could tell a lot of story in just a couple of minutes on your part.

Hope some of that helps, and that we get you squared away!