Question

New validation error after upgrading to zapier-platform-core 15.0.1

  • 20 July 2023
  • 2 replies
  • 81 views

Userlevel 1

Hi, I’m experiencing a new validation error after upgrading to "zapier-platform-core": "15.0.1". Every search I have is getting the same validation error: 

additionalProperty “important” exists in instance when not allowed.

 

I’ve tried going to the link to documentation displayed in this error message, but it give me a 404 not found. I’ve also tried throwing out the build files and regenerating them, but this doesn’t work either.

Has anyone else run into this? Thanks,


2 replies

Userlevel 3
Badge +6

Hi @charlotte_anne , 

So sorry to hear about that error!

As you hinted, it sounds like this is related to the 15.0.0 release, where the important field property was deprecated:

https://github.com/zapier/zapier-platform/blob/main/CHANGELOG.md#1500

If you haven’t done so already, it might help to try removing important from input fields.

Otherwise, please feel free to reach out to our Platform Support team, and they’ll be glad to take a look!

https://developer.zapier.com/contact

Userlevel 1

I have reverted to "zapier-platform-core": "14.1.1" and it is working. I’m not sure if there is a problem with 15.0.1 in general or if it just doesn’t work with code written before 15.0.1.

Reply