Best answer

"Error parsing response." in Zapier when Postman Returns Successful Object

  • 30 July 2021
  • 1 reply

Userlevel 1

I have an API call that I tried to add to Zapier. 

This API works perfectly on Postman.. but, when using the same parameters on Zapier API request, I am getting an error. I would appreciate any help on this. 


API Request Header (Postman)


API Request Header (Zapier)


API Request Body and Success Response (Postman)


API Request Body (Zapier)



Error from Zapier


As per other comments on this community, I tried to check further logs on “Monitoring” section and that doesn’t help. Below are screenshots.. 



I do not know what I am missing. I would appreciate help from the community. 


Best answer by Zane 31 July 2021, 01:39

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +9

I notice that in Postman you’re using a form data content type for the body of the request. Zapier is going to send data to your endpoint as application/json by default, and encode the body as a json string. It’s possible your endpoint is not be able to parse that correctly and is just returning an empty response? Try setting the content type to match what your server expects.  I think if you set a Content-Type header of application/x-www-form-urlencoded, the supporting library used is smart enough to encode it correctly without having to drop into code mode and do anything else special. 

A handy Postman tip is to use their “console” section (link at button of their UI) to see the actual details of the headers they sent in the request and use that to look for differences between what a Zapier request is doing.  Super useful when one is trying to figure why a request is working in one place and not the other!