Best answer

Dynamic fields not getting populated correctly with previous action values

  • 18 October 2022
  • 5 replies
  • 295 views

Userlevel 1

Hi all,

    we are creating a custom Zapier integration. All worked pretty well until a few days ago, when we experienced a strange behaviour: we created a Zap which creates a Google Cal appointment when an appointment is created on our custom applicaition.

 

The 1st step works correctly, and Zapier receives the appointment data (Appuntamento is Appointment in italian):

 

The 2nd step doesn’t work:

 

 

As you can see, instead of the dynamic fields, Zapier fills the values with values like {{XXX_fieldName}}.

here’s our action:

 

We tried to delete the Zap and recreate it from scratch, but nothing changed.

All worked correctly until a few days ago. I don’t know if it is related, but we have just changed the configuration of our triggers, actions and authentication - the urls changed, because we switched from a dev server (ngrok variable address) to a test server (public address). The variable part of the urls is stored in a env variable.

Please can you help us?

Thank you in advance,

 

Barmassimo

 

 

 

 

icon

Best answer by shalgrim 21 October 2022, 20:53

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +8

Hi @barmassimo , 

 

The value you are seeing is the “old” value Zapier had during the mapping. In order to fix this, you would need to go to the Trigger step and refresh the test data (Load More) then map the values again. This should fix it :) 

Userlevel 1

Hi @barmassimo , 

 

The value you are seeing is the “old” value Zapier had during the mapping. In order to fix this, you would need to go to the Trigger step and refresh the test data (Load More) then map the values again. This should fix it :) 

We tried to load new elements in our trigger step, but It didn’t help. Maybe, Is is because we didn’t set the “Perform List” (the endpoint URL Zapier should check for recent items) in our trigger.

Is it necessary to set the url for “REST Hook” triggers? What should it return? An array of elements with random ids?

Thank you very much for your help.

 

Barmassimo

Userlevel 7
Badge +8

Hi @barmassimo 

 

I dont know your current setup so its a but hard for me to point at the problem but that can definitely be an issue specifically that after the update you made you cannot pull test data even. 
 

The value you see in the zap {{xxxxx_start date}} is zapier’s reference of the field , and since it shows this way it means Zapier cannot find this field (or the field is null) . I would revert back to the earlier version or configure the end point. 

Userlevel 1

Hi,

    finally, I found the problem: I was sending the notification (trigger) parameters with a wrong case (“Description” vs “descriprtion”).

The strange thing is, the 1st step (trigger) mapped the parameters correctly (see screenshot on the previous messages) and didn’t stop despite some of the parameters were mandatory.

It seems that, on your side, some part of the elaboration is case-sensitive (parameter passing between actions), and some parte isn’t (notification parameter handling).

After fixing the parameter names, all is ok.

Thank you for your support.

 

Barmassimo
 

 

 

 

Userlevel 6
Badge +8

So glad you found the fix, Barmassimo, and shared it with the community!