Best answer

Webhooks not appearing in Zapier when payload sent without line breaks

  • 27 May 2021
  • 3 replies
  • 103 views

Userlevel 2
Badge

Hello, 

 

I am using Jira Automation to send simple updates to a Zapier webook.  This works intermittently.

The Jira automation is set up to send the following text when a comment is made on an issue for a project:

   {
      "Issue Key": "{{issue.key}}",

      "Update Made By":  "{{issue.comments.last.author.displayName}}",

      "Message":  "{{issue.comments.last.body.text}}"
  }

So if a comment is made on Jira issue  ZZ-123 by Joe, like this:

     I just tried this with Fred.

The payload post to Zapier is sent like this:

   {
      "Issue Key": "ZZ-123",

      "Update Made By":  "Joe",

      "Message":  "I just tried this with Fred."
  }

 

All good, and Zapier sets off the workflow as normal. 

However, sometimes Jira sends the payload body like this:

   { "Issue Key": "ZZ-123", "Update Made By":  "Joe", "Message":  "I just tried this with Fred." }

As this is text, there should be no difference, but for some reason the Zapier task history does not even acknowledge anything was received.  I have tried using both Put and Post from Jira, but no difference.  I also tried putting in a line break like ‘\n’ or ‘\\n’, but that appears as \n in the payload.

The examples above are observed when using the ‘Validate your webhook configuration’ tool in Jira.

There are no headers configured in Jira either.

icon

Best answer by Troy Tessalone 27 May 2021, 18:49

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +14

Hi @AshleyMorris 

Check out this help article about data deduplication in Zaps that may help explain your issue: https://zapier.com/help/create/basics/data-deduplication-in-zaps

If you can, add a timestamp to the payload being sent from Jira to ensure the payload will always be seen as unique by Zapier.

Userlevel 2
Badge

I tested this by using a series of random strings to ensure unique posts to the Webhook.  Each time the payload was ‘word wrapped’, the Webhook does not even register it.  Each time the payload had line breaks (as shown in Jira automation test tool) it registered on the Zap as received.

 

There does not appear to be a way for me to debug this any further as the Webhook always replies with a 200.  I have also tried this with different Hook URL  hosted by Zapier, and using the legacy and current Webhook trigger from Zapier.

Userlevel 7
Badge +14

@AshleyMorris 

The line breaks in the JSON code shouldn't matter.

I suggest opening a ticket with Zapier Support so they can investigate further: https://zapier.com/app/get-help