Question

Webhook returns hydrated file - not json

  • 16 January 2024
  • 8 replies
  • 95 views

One of my perfectly working workflows suddenly doesn´t work anymore: I`m sending a POST request to a PHP script on my server. This PHP file should (and always did) output a string. Suddenly Zapier returns a hydrated file instead of my String/JSON - Why?! The PHP file certainly doesn´t respond with a file. Even the simplest PHP script like <?php echo “Test” ?> is outputted by Zapier hydrated.

Whats wrong?

 

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @Paul Metzger 

Can you help us have a better understanding with how you are trying to use the file in following Zap action steps?

Hey Troy, sure. The “sub zap” is triggered by a Stripe Event (“New payment”). The Webhook (as seen in the screenshot above) sends a request to my bookkeeping API (SevDesk). This api provides a Ticket-ID which is returned by the PHP-Script. But instead of returning the ticket-ID Zapier gives me this hydrated text?! Why?

 

To reproduce this problem you can setup any PHP script and try to request it via POST Webhook.

 

Thanks in advance.

Userlevel 7
Badge +14

@Paul Metzger 

Did anything change recently with the SevDesk API?

You may want to reach out to SevDesk to inquire about their API endpoint response.

Can you post screenshots with how your POST request is configured to give us more context?

 

If you suspect an issue with how the POST request response is being handled by Zapier, then you may want to open a ticket with Zapier Support: https://zapier.com/app/get-help

Thanks for the fast response. Its certainly not a SevDesk problem because Zapier doesn´t return ANY value. No matter what the Script does. Let me explain it further with more images:

 

So lets say I want to request this script:

https://bauanalyse.com/sonstiges/easy_script.php

It should output a Ticket-ID like so:

 

Source-Code of the PHP-Script:

 

 

I request the script in Zapier like so:

 

 

More details of the request:

 

 

Request test outputs:

 

 

The output is a hydrated file?! It should output the ticket-id ( 420924742 ) instead!?

 

Userlevel 7
Badge +14

@Paul Metzger 

Are you using POST or GET requests? (couldn’t tell from screenshots)

POST.

Userlevel 7
Badge +14

@Paul Metzger 

In your Zap Runs, you can now see the LOGS to help you troubleshoot: https://zapier.com/app/history/

 

Now it works. Must have been a bug...