"Update Issue in Jira Software Cloud" is not working

  • 21 February 2021
  • 3 replies

Hey there!

I'm trying to update the Jira Ticket Approver, when access to a specific Service is requested. To search the Approver i use Bamboo.

Here are the steps I did so far in the zap:

  1. Trigger the Zap only for Specific Tickets (with a JQL)
  2. Find the Ticket Reporter in Bamboo (also find his Manager / Supervisor)
  3. Update The Issue

There appears a Error in step 3. I get the error message “Zapier had trouble retrieving custom fields from Jira Software Cloud” and “We’re having trouble loading ‘Status’ data”.

I searched for a Solution and found this community thread:

I wanted to try this workaround, but because i am an absolute beginner with webhooks i wanted to reach out to you guys and ask for help ^^

How can i change the Approver and the Status of the Ticket with a webhook.

I tried to create a Webhook in jira scoped on a JQL but i have no idea in this Part:

What URL do i have to use? Where can i find the JSON Data and if i update it here does the Ticket get updated?

Thanks a million guys in advance ^^



This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

I also found the Original Post with this reply at the Bottom from @arkhamknighthell ^^ :

tried a couple of thing regarding this, like making a catch trigger from within Zapier, but that did not lead to what i wanted. i read through the Jira REST API documentation, but this just confused me a little more 」( ̄▽ ̄」)

Soooo yeah,
i read a lot but still could not figure out which URL i need to add in there, because when i catch a hook (create a URL in Zapier) i can fetch the Issue Data…

But when i want to update the Ticket i can’t do it. And at the Moment i am out of ideas ^^

i am ready to try anything ^^

Thanks in advance guys ^^

Huge News guys ^^

i managed to get the URL from the Documentation,

and added the Update JSON,

however rn i am getting an Error stating that the basic Auth won’t work in Jira anymore:

Deprecation of basic authentication with passwords for Jira and Confluence APIs - Atlassian Documentation

how can a select to add an API token?

Thanks guys ^^