Best answer

"Missing value" error but value is shown in data out overview

  • 23 March 2022
  • 4 replies
  • 297 views

Hi,

I made a zap for a client with the connection of a ‘private’ app with webhook. The app’s name is Plug&Pay. It’s a check-outplatform and I send a discount code from that app to Zapier. In my Zap history I can see in the ‘data out’ overview that this discount code is visible. The discount code is a field I can select in the Zap filter.

But when I run a test and filter on that value in my Zap, I get ‘missing value’ and the zap stops running. 

Did anyone ever encountered this? How can I solve this?

Thanks in advance

PS: see attachment

icon

Best answer by Troy Tessalone 23 March 2022, 17:08

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @Titine 

Can you please reupload the screenshot, thanks.

 

Hi Troy,

Hope it works now?

Userlevel 7
Badge +14

@Titine 

Try changing your trigger test data, used to configure the Zap, and remap the Zap Filter step.

https://zapier.com/help/create/basics/change-the-test-data-in-your-zap-trigger

Hi Troy,

Thank you. I have totally recreated a new Zap and made a new test order. When I do that it says that it doesn’t find new orders while I just placed one. So, I still only can see the one of John Doe. And the zap history tells me it now even doesn’t accept the discount code of John Doe anymore 😕.

In the meanwhile I have found a workaround to reach the goal the first zap should have realized with the discount code. So, for now I am saved. But I still wonder why this is not working and would like to figure it out because it’s a common filter I will have to use. So, thanks for any help.