Best answer

Zaps Not Trigger FB Leads to Run Through Mailchimp

  • 9 August 2022
  • 4 replies

Hi Everyone!


I have set up a few Zaps to run through:


Facebook Lead (For Business Admins) → Add a Subscriber to Tag in Mailchimp → then once tagged in Mailchimp it sends out an existing campaign.


I have gone through and checked all FB permissions and made sure Mailchimp is connected to FB as well as turned the Zaps on and off and no luck.


The Zaps are not being triggered at all and I am currently stuck manually adding the leads to the tags.


Anyone have any advice?


Best answer by Breanne - SMG22 11 August 2022, 19:30

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +9

Woohoo! I’m so excited the team was able to get this up and running with you!

Thank you so much for swinging back around to update the Community with your solution too! We love to see it. 🎉

Userlevel 7
Badge +9

Hey there, @Breanne - SMG22!  Thanks for reaching out and I’m sorry to hear you’re running into this!

Facebook Lead Ads is a bit of beast in terms of permissions! While I know you mentioned you walked through this previously, I wanted to be sure to reference this doc in particular. It walks through each individual place to check:

This one is also helpful to reference for testing and checking issues.

If after running through those troubleshooting steps, you’re still running into issues, I’d recommend opening a ticket with my teammates in support and sharing the specific zap you’re working on. You’re also welcome to link them to this topic! They’ll able to review details of your setup, including logs that should help get to the root!

Please keep us posted on your progress! We definitely want to make sure you’re all squared away.

@christina.d Thanks for the articles, I have gone through all of them and checked the permissions. I did have to enable some that were not enabled but still no luck triggering the Zaps. It is odd, sometimes the Zap triggers and other times it doesn’t. It still shows no Zap history though, so strange.


I have put in a ticket to explore this further as I have checked everything at length. 



Here is the solution to the issue I had! I had set custom permissions for Zapier in my FB Ad account but you have to give it DEFAULT access so that it ensures all the permissions are accepted.


Here is the solution the wonderful Zapier Support Member gave me that solved my issue:


It might be that Zapier needs CRM access. Let's try the following steps to see if we can get this working:

  1. Make sure that Zapier has full access under the CRMs tab. You can get instructions here - scroll down to "To assign leads access permissions to CRM systems"
  2. The Facebook Page Owner needs to click on "Restore Default Access": Go to FB Business Manager and Select the Page | screenshot > Click on "Restore Default"
  3. Add a new connection for FB Lead Ads under the ‘My Apps’ section of your Zapier account and you should then be able to connect with the Page, pull in a sample (if there is one), turn the Zap on and trigger it.