YouTube error: The app returned "Media type 'text/plain' is not supported.

  • 10 July 2023
  • 3 replies

I have tried to set up a Zap that transfers new videos in a Facebook group to youtube.

I have set it up like this

  1. “new video” trigger
  2. delay of two hours (so that the zap doesn’t fail due to the video still being recorded)
  3. create video in youtube
  4. and then some other stuff that is not relevant for this question.

For some reason the third step keeps failing with this error message: “The app returned "Media type 'text/plain' is not supported.".”. I have tried appending all types of data to the “video” field (the video file itself) in youtube, but this keeps happening, no matter what the data type.

Any ideas on what i should feed into youtube to make it accept the facebook group video?

3 replies

Userlevel 7
Badge +6

Hi @Anders Nedergaard,

I’m so sorry to hear about the troubles with the Zap.

Before we dig deeper into this, would you mind sharing a detailed screenshot of how your Zap is configured? Also, a screenshot of the “Action” section of the YouTube step that shows all of the fields? Here’s a sample screenshot:

(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks! 😊

i have attached screenshots of the appended metadata for the youtube upload that fails


When i append the “post permalink” or “source” metadata  to the video field and run a test, the test turns out succesful.


Nevertheless i get the attached error message everytime, no matter what kind of data i append to the video field.


Thank you ;o)


Userlevel 7
Badge +6

Hi @Anders Nedergaard,

Thanks for the additional details and screenshots!

I looked at the screenshot, and it looks like the issue here is the mapped data in the “Video” field in the YouTube action step. The “Video” field looks for the file object of the video or the direct URL of the video:

(view larger)

That said, the direct URL link of the video from Facebook Groups should be the “Source” data. Is the “Source” data is being returned by the trigger? If not, could you please try doing these troubleshooting steps for me?

  1. Turn off the Zap.
  2. Reconnect your Facebook Groups account here:
  3. Upload a new video on your Facebook Group
  4. Load in the new video as a sample data in the trigger step.
  5. Now, if the “Source” data is returned by the trigger.
  6. Remap the “Permalink URL” to the “Source” data.
  7. Turn on the Zap, and trigger the Zap.

Please give that a try, and keep us posted! 😊