You passed {raw: true} in request() - the response.content property is not available! Try response.body.pipe() for streaming, response.buffer() for a buffer, or response.text() for string.


10 replies

Userlevel 7
Badge +14

Hi @derek1508 

To give us more context, post screenshots with how your steps are outlined and configured along with the encountered error message.

here is a video link of the steps:

Userlevel 7
Badge +14


You may have to try process of elimination to determine the root issue.

Since you only have 2 fields mapped to the LinkedIn step, try removing each and testing separately to see if one is causing the error.

Issue may be with the format or length of the Content.

Issue may be with the image URL not being publicly accessible.

Help article about using files in Zaps:


Thanks Troy, I was unable to solve the error. Are able to help?

Userlevel 7
Badge +6

Hi there @derek1508,

I’m jumping in to see if I can help!

Have you tried publishing the Zap by clicking on the “Skip test” button? Does the Zap still receive the same error after running it live?

I'll be keeping an eye out for your response!

Hi Ken, I have skipped the step Like you mentioned. It still doesn’t seemed to have fixed the error, I am not sure what else to do?

Thanks for your input Ken. I tried what you said and it didn’t seem to work. What other options do I have?

Userlevel 7
Badge +6

Hi @derek1508,

Thanks for giving that a try!

I have a hunch that the issue is related to how the response from OpenAI is being handled in Zapier. The "{raw: true}" error usually indicates that the data from OpenAI is arriving in a format that Zapier can't process directly. This usually happens when the data is too large or in an unsupported format.

Could you please try replaying the Zap run by clicking on the “Replay Zap run” button? 447cc6de9a5436ec1ff41c2d9e523815.png

More about replaying Zap runs here:

Kindly give it a try and let me know how it goes? I'll keep an eye out for your response!

Thanks for your response Ken. I followed what you said and it came back like this. I am not the best with automation so I am finding it difficult to find solutions to solves this. What do you think from this video recording?

Userlevel 7
Badge +6

Hi @derek1508,

Thanks for giving that a try.

I would suggest contacting our Support Team regarding the issue you are facing. Our Support Team possesses the necessary tools to view the logs of the Zap and identify the root cause of the problem.

You can reach our Support Team here:

I appreciate your patience and understanding.