Best answer

Xero New Purchase Order Not Triggered

  • 29 November 2022
  • 5 replies
  • 108 views

Userlevel 1

Hi all,

I created a new Zap where it retrieves new purchase orders and their information. The following actions work perfectly fine, however, the initial call to find the new purchase order never actually finds the new purchase order I create, even after manually running it about 30 minutes after I created the Xero purchase order.

Another thing to note, is that when I run the test in the Zap, it retrieves purchase orders but from the beginning of Xero, rather than the most recent purchase order. 

Wondering if anyone could help with this :)

icon

Best answer by christina.d 2 December 2022, 21:33

View original

5 replies

Userlevel 7
Badge +9

Hi @blairandrews 

Can you share a screenshot of the configuration in the trigger step? Also mention which zapier plan you are using.

 

 

 

Userlevel 1

Hi @blairandrews 

Can you share a screenshot of the configuration in the trigger step? Also mention which zapier plan you are using.

 

 

 

Hi there,

I am currently on the 14 day professional free trial just to confirm that Zapier would work for the business I work for before we make any full commitment. Here is the screenshots of the trigger configuration:

Everything seems to be set up correctly, and as you can see the test trigger pulled a purchase order from 2014 which is bizarre. 

Userlevel 7
Badge +8

Hi @blairandrews! Test Triggers will pull older information since it’s just a test, and anything that occurs, say during the time you set this up, will not populate. It’s just a sample that indicates the type of information you will receive, but not the sole data you will pull everything. Does that make sense? 

Your Zap appears to be set up correctly, and nothing sticks out. Can you please add screenshots of your Action too? While I don’t see anything that sticks out in the trigger this could very well be an issue with the mapping of the fields. You can check out the article linked for more info. 

If you aren’t comfortable sharing more screenshots, you can also reach out to support for a more 1:1 look at what’s going on. 

Userlevel 1

Hi @blairandrews! Test Triggers will pull older information since it’s just a test, and anything that occurs, say during the time you set this up, will not populate. It’s just a sample that indicates the type of information you will receive, but not the sole data you will pull everything. Does that make sense? 

Your Zap appears to be set up correctly, and nothing sticks out. Can you please add screenshots of your Action too? While I don’t see anything that sticks out in the trigger this could very well be an issue with the mapping of the fields. You can check out the article linked for more info. 

If you aren’t comfortable sharing more screenshots, you can also reach out to support for a more 1:1 look at what’s going on. 

That all makes sense, thank you!

However, I am still unfortunately having issues with even just making a simple Xero purchase order trigger with an email with Zapier action. When I manually ran the Zap it says it didn’t find a recent purchase order, so I will head to support to see if I can get a solution. :)

Userlevel 7
Badge +9

Hey there, squad! I wanted to pop in and and share some of the insight from the support ticket.
Bad news 🐻 : this is a known bug within Xero where the “New Purchase Order” isn’t triggering on new PO’s. 😣

The OP was added to the bug report as an impacted user and we’ll email once a fix is in place. There’s a main thread below that our team will also update once that takes place.

If you’re interested in following along in community, I’d recommend subscribing to that thread. 👆🏽

I’m so sorry to not have better news but as always appreciate you flagging this in the community.

Reply