Question

WordPress Unable to pull users

  • 27 July 2023
  • 7 replies
  • 55 views

Trigger : New user in wordpress → Create Candidate in Bullhron CRM
Error from wordpress trigger and not allowing the Zap to be turned on.
Wordpress is linked with zapier own account of Admin instead of SuperAdmin

A user will create and account using User Registration Plugin
 

Unable to pull users 
Step 1 - New User in WordPress 

Error code: Error while retrieving: Error parsing response. We got: "<!DOCTYPE html> <html lang="en-US"> <head> <meta charset="UTF-8"> <meta name="viewport" co"

 

 


7 replies

Userlevel 7
Badge +14

Hi @pbower 

Good question.

Have you reviewed all the available help articles for using WordPress in Zaps?

https://zapier.com/apps/wordpress/help

I’ve reviewed many answered and unanswered tickets but can’t find anything describing my issue or possible work around.

This is the error message i get one while testing the Zap and One from the email and they both say the same thing

Unable to pull users - ZAP
Step 1 - New User in WordPress - EMAIL

Error code: Error while retrieving: Error parsing response. We got: "<!DOCTYPE html> <html lang="en-US"> <head> <meta charset="UTF-8"> <meta name="viewport" co"

 

Userlevel 7
Badge +14

@pbower 

The error message appears to be truncated.

Are you able to provide the full error message? (preferably as a screenshot)

Error code: Error while retrieving: Error parsing response. We got: "<!DOCTYPE html> <html lang="en-US"> <head> <meta charset="UTF-8"> <meta name="viewport" co"

Unfortunately that is all I get from the error message, in the email too.

 

Userlevel 7
Badge +6

Hi there @pbower,

Before we dive further, let's take a look at the Yoast SEO plugin since we've encountered some issues with it in the past. One of our other customers managed to resolve a similar problem by disabling the 'REST API: Head endpoint' setting in the Yoast SEO plugin. You can find the instructions on how to do this here: https://yoast.com/help/how-to-disable-or-enable-the-rest-api-endpoint-in-yoast-seo/

Additionally, it would be super helpful if you could share a screenshot of how you're attempting to log in with WordPress to Zapier. We're specifically interested in seeing how you're entering the Base URL in the "Base URL" field while connecting the account. Here's an example screenshot for reference:

870f8726cfc0b2ae438f73815730355c.png
(view larger)

Please keep us posted! 😊

Afraid after leaving the REST API Endpoint disabled and turn the Zapier plugin on and off again, recconnecting to WordPress, i’m still getting the same error message.

Base URL used is with Zapier having it’s own account of admin
https://www.SITENAME.com/

I’ve recreated the connection after and received a messages say that the REST API is required. I re-enabled it and created a fresh connection with eh same outcome.

Userlevel 7
Badge +6

Hi @pbower,

Thanks for the update.

Could you please try disabling "Restrict Content" and the WPassword plugin? This has also fixed the issue for some users.

Also, disabling security-related plugins like JetPack could fix this issue.

Please keep us posted.

Reply