Why does "Find a Member in Ghost" Action returns always empty data

  • 31 August 2022
  • 5 replies

Userlevel 1

It doesn’t matter how o what email I setup for search, the “Find a Member in Ghost” action always returns “No data available”

I’ve tried searching for emails having “free”, “subscribed”, “comped”, statuses and also defining the email search field manually, and with data from other steps.

Any idea on how to get valid data in return?
¿Or simply how do I get the “member id” belonging to an email in Ghost?



This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +8

Hi @hjbarraza , 


This happens with certain apps (but I've seen it happen when doing a delete action, not with a find action). HOWEVER, if you create the next step you normally see the data coming form this step. Have you tried that?  

Userlevel 1

Thanks @MohSwellam 
Unfortunately I do have steps afterwards and their variables have no data coming from the find step.
: (

Userlevel 7
Badge +11

Hi @hjbarraza!

I also use Ghost and have noticed this as well. I thought maybe once the Zap was turned on that I would be able to retrieve a member, but I don’t appear to be able to :(

It appears there may be a bug of some sort here. I’d suggest that you contact our Support team so they can confirm that and then log the bug properly. That will ensure that the Ghost team is notified about it. 

Hopefully it gets fixed, because I also have a workflow that depends on me finding a Ghost member.

I checked out the Ghost API docs to see if it’s something I could figure out using Webhooks by Zapier, but their authentication method is a bit over my head.

Userlevel 2
Badge +1

@nicksimard were you able to solve this?  I have a prospect with the same issue

Userlevel 1

@nicksimard were you able to solve this?  I have a prospect with the same issue

We were able to complete the process. By defining the next steps with empty data. 

we just had to Trust that the process would be completed if data existed. 

Let me know if you want screenshots of our setup.