Best answer

Twitter feed for Discord posting links of tweets and sometimes the embeds of the tweets

  • 11 September 2020
  • 3 replies
  • 2359 views

Userlevel 1

Hello I have a twitter feed linked to my discord server. And have it set to post the URL of the posts and that normally shows an embed of the tweet. But has been doing a lot of the time where it just posts the link and no embed of the tweet. Is there a way to fix this issue so I can have it post the embed of tweets?

icon

Best answer by Wemakefuture 11 September 2020, 06:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 6
Badge +7

@dreamleaf discord intakes the HTML description of the post. Let me give you a short intro on how this works https://metatags.io/ here you can check the meta tag of the URL. Discord should then automatically pull in the info and preview the tweet. In somecases the preview is not loaded in time before the post was done. So maybe updating the post can solve this issue for you.

 

Userlevel 1

@dreamleaf discord intakes the HTML description of the post. Let me give you a short intro on how this works https://metatags.io/ here you can check the meta tag of the URL. Discord should then automatically pull in the info and preview the tweet. In somecases the preview is not loaded in time before the post was done. So maybe updating the post can solve this issue for you.

 

@Wemakefuture  If I understand correctly the Zap is posting the tweet to fast in the discord for it load properly? Is there a way to delay the Zap from posting by a few mins so that it can post it more properly? Or is that not the issue? Heres a photo of what I’m getting. 

 

Userlevel 6
Badge +7

The post is done over an API so it is at the discords end. There is no chance to delay it. You might be able to solve it by updating the post within Zapiers discord App. You could reach out to the support of discord and show them your issue maybe they can add a "payload/meta tag" - delay. It is rather a discord issue then a Zapier one.