Best answer

"The groups.0 must be a number."

  • 21 September 2022
  • 2 replies
  • 9 views

I’m trying to connect Airtable and Mailerlite, such that when I add or update a client in Airtable, they’re automatically added or updated in Mailerlite.

In Airtable the relevant fields are:

  • Group (single-select, corresponds to Mailerlite groups)
  • Status (single-select, active or inactive, corresponds to Mailerlite’s subscribed and unsubscribed)

I connect the Group field to the Subscriber group. I have the option of picking a static subscriber group, where the groups correspond to a string of digits.

Different clients in Airtable, though, correspond to different groups. I don’t want them all to join the Mailerlite group “Independent” or all to join “private”. So I try to connect this to the single-select field “group”.  

But when testing the step, I get a strange error: "The groups.0 must be a number."

I tried setting up a formula field in Airtable that returned one of the strings of digits I mentioned earlier, depending on whether the client is “personal” or “independent”. But the field doesn’t appear as an option in Zapier; I don’t know why.

Any ideas about next steps toward a solution here?

 

 

icon

Best answer by Troy Tessalone 21 September 2022, 18:07

View original

2 replies

Userlevel 7
Badge +14

Hi @Sigurdur130 

Good question.

If you are trying to use an Airtable Formula field, then make sure to pull in the newest trigger examples to use to configure and test your Zap steps.

How to change your trigger test data: https://zapier.com/help/create/basics/change-the-test-data-in-your-zap-trigger

NOTE: Airtable only returns fields that have values.

 

The Mailerlite Subscriber Group field expects the internal numeric ID value.

 

ALTERNATIVE
In Airtable, you can use Linked records and use a Lookup field to get the correct Subscriber Group ID.

Help article that explains the concept of a Lookup Table: https://zapier.com/help/create/format/create-lookup-tables-in-zaps

Thanks for an excellent answer, Troy. I’ll try linked records to make this work =) 

Reply