Question

Stripe error: The app returned "This customer has no attached payment source or default payment method.

  • 1 August 2023
  • 3 replies
  • 418 views

Userlevel 1
Badge

Hello Everyone !

 

I have a zap that triggers the Stripe create subscription (legacy) every 1st of the month. 

The client already exist in Stripe before the zap, and already made a first payment, so i have their card info. I do a search to find the client by their cus_ID, and create the subscription. 

 

It worked but I now have this error “

The app returned "This customer has no attached payment source or default payment method. Please consider adding a default payment method. For more information, visit https://stripe.com/docs/billing/subscriptions/payme...". 

 

I can’t seem to find a way to l use their card, or to set it up as default payment method. 

I did the setup manually, I went into stripe and set a client’s card as default payments method, and ran the zap, which was successful. 

 

But how can I make my zap work?

 

 

Thanks everyone!


3 replies

Userlevel 7
Badge +6

Hi @Wellow123,

Thanks for updating us!

Please keep updating us after conducting some tests on your end. 😊

Userlevel 1
Badge

Hi @Troy Tessalone 

Thanks for your feedback.

I’ll run some tests with the new one. It’s weird as it’s the first time it happens

 

 

Userlevel 7
Badge +14

Hi @Wellow123 

Good question.

One thing to try is to use the newer version of the Stripe Zap app integration, meaning the non-legacy version.

Reply