Best answer

Pipedrive to Mailchimp - single-option fields not showing values, only IDs

  • 21 April 2023
  • 4 replies

I have a similar problem to the person in the post below. I have single-option custom fields in Pipedrive, and when I use Zapier to update Mailchimp with data from those custom fields, I only get their IDs and not their values (e.g. instead of Option1 as the value, I only see the ID number, e.g. 20). The post below (10 months old) suggests that the problem has been fixed, but not for me. Does anyone else know how this can be resolved?



Best answer by ken.a 25 April 2023, 20:25

View original

4 replies

Userlevel 1

This still seems to be an issue over a year later? I’m only retrieving codes. Can we add in an IF step to translate the code?

Userlevel 7
Badge +6

Hi there @anglonz,

I hope you’re doing well.

It seems that you've already been in contact with one of our Support Specialists, and I'm sorry to report that the issue you're encountering is a known bug with the Pipedrive integration. Here's the response our Support Specialist provided:

I have been doing some digging on the issue, and I see that a few other users have been running into the same problem. As it turns out, what we're seeing is a known bug that is different from the community article suggested.
There's a bug report in place, and I've added your contact information to it. At the moment, a workaround isn't available, but we'll get back to you right away when a fix ships for the problem.
Fully appreciate hitting a dead end here isn't ideal, please feel free to reach out with any questions in the meantime!
Although the ticket may show as "Solved," this only refers to the ticket’s status. We'll notify you via email when the bug is fixed. If you have any additional questions or concerns, please feel free to open a new ticket or reply here to reopen this one. We're always here to support you!

For anyone else following along, this is a bug with the Pipedrive trigger where it is only getting IDs of Enum (dropdown) fields, not the actual value. While we cannot provide an ETA on when the bug will get fixed. We will be sure to share them in this thread.

If you have any questions about the bug, please feel free to continue the conversation with one of our Support Specialists.

Thank you for understanding.

Hi Charie,

Thanks for your reply!

Screenshots below, this has been happening since I’ve been using Single-Option Fields in Pipedrive. All other fields work fine. This is my first zap that I’ve tried using any of the single-option fields though.

Above is the zap overview, each stage shown below:
Notice the fields ‘Condition’, ‘Pet Type’, ‘Pet Insurance’ & ‘How did you hear...” are all single-option field types in Pipedrive so the data needs to show the values not the IDs.



Userlevel 3
Badge +4

Hi @anglonz 

Thanks for reaching out to the Community!

Can you share screenshots of how you’ve configured the steps of the Zap? (If there’s any personal information, kindly blur them.)

Also, to ensure we’re on the same page, is the issue happening since you created the Zap? Or is it happening just recently?

Looking forward to your response.