Best answer

PhantomBuster didn't respond in time error

  • 2 October 2021
  • 5 replies
  • 164 views

To whom it may concern, 

I’m using PhantomBuster in one of my Zaps. It appears to respond later than 30 seconds sometimes.

In such cases the Zap is going to raise an error. I looked into PhantomBuster logs and realized in these cases the response time is just a little bit higher than Zappier limits.

I understand that Zappier can't wait too long for third party apps, but in my observations, increasing the waiting time for PhantomBuster from 30seconds to just 45seconds is enough for doing the job.

I looked into Zappier's community and realized that I'm not the only one having this problem. Of course 45 seconds might not be sufficient for some users but will definitely solve the issue, some of them are having.

I appreciate your comprehension
Looking forward for good news form you

icon

Best answer by SamB 6 September 2023, 18:12

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +11

Hey @hidata

Thanks for reaching out about this and welcome to the Community! :)

I’ve been looking into this and it seems there’s an existing bug report open for this behaviour with the PhantomBuster app integration. So I’ve added you to the list of affected users. I don’t have an ETA but we’ll send you an email notification as soon as the app’s developers are able to resolve the issue.

In the meantime, if a PhantomBuster step does hit that timeout error, if you try replaying that errored run of the Zap a little while later, it may then be able to go through successfully. Hope that helps!

Userlevel 7
Badge +11

Hi friends! 👋

Just popping by with a quick update to share that the bug report has been closed! There’s now an option to set the parameter Wait until the Phantom produces an output to true, which will allow the action to exceed the 30 seconds and prevent a timeout error. Make sure to only use this parameter setting for Phantoms with a short execution time though.

For Phantoms with a long execution time you’d want to keep it set as false, and create another Zap with that uses the New Output trigger to retrieve the Phantom's result when it's ready. 

Hope that helps! 🙂

Userlevel 7
Badge +12

If anyone is trying to do the same thing, @JCM found a workaround for this using webhooks. They explain it in their post here: Work Around PhantomBuster didn't respond in time error

Userlevel 6
Badge +6

Hey @hidata ,

 

Can you post the screenshot of your Zap? Also, Can you even post the screenshot of the error?

Userlevel 7
Badge +7

Hi @hidata ,

Like you say, this has been requested more often by the community but most likely won’t change any time soon. However, what you could try to do as a workaround / fix is using webhooks on phantombuster:

  • Zap 1 triggers phantombuster to do something then stops
  • Zap 2 has a webhook and waits for success from phantombuster

You can read about this here: https://hub.phantombuster.com/docs/using-webhooks

Hope this helps.

~Bjorn