Question

Newly created fields not appearing on Zap

  • 13 June 2022
  • 7 replies
  • 2604 views

Userlevel 1

We have created a new field on Salesforce and we’re planning to sync it to Jira. However, we cannot see this new field on the Zap. 

 

Steps Taken:

  1. Refreshed browser
  2. Duplicated the Zap
  3. Logged out and logged in the logins to connect to both Salesforce and Jira
  4. Used google incognito to make sure caching is not an issue
  5. Made sure the new field is accessible the log-in we are using

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @DCCP 

Good question.

Custom fields/objects not loading

Sometimes when you add custom fields or objects in Salesforce, there is a delay between when they will appear in the Zap editor. To fix this with a trigger you can scroll to the bottom of the Salesforce Object menu and select to reload and bring in new choices.

If you are dealing with actions, here's a couple steps that may help:

  • Hard refreshing the page (Shift+F5 on a PC or CMD+Shift+R on a Mac) a couple times
  • Click ‘Refresh fields’ at the bottom of the Zap step
  • Copy that Zap and edit the copied version to see if the fields appear
  • Recreate the Zap from scratch
  • Wait a while longer, sometimes it takes a little while for the cache to refresh with those fields
Userlevel 1

Hi Troy,

 

All of the recommendations has been done except to recreate the zap from scratch (Should that be necessary? Isn’t duplicating the zap the same thing?) . The field has not shown for more than a week now that is why I reached out to the community.

 

Userlevel 1

Hi Troy,

 

I am able to make it appear by generating a new “Test Record”. I think that needs to be added to your KB as well as additional troubleshooting steps.

Userlevel 7
Badge +14

Hi @DCCP 

Please submit this feedback via a ticket to Zapier Support as I do not work for Zapier: https://zapier.com/app/get-help

Hi Troy,

 

I am able to make it appear by generating a new “Test Record”. I think that needs to be added to your KB as well as additional troubleshooting steps.

This worked!

Hi Troy,

 

I am able to make it appear by generating a new “Test Record”. I think that needs to be added to your KB as well as additional troubleshooting steps.

I had to do both refresh fields and generate new test record. These two brought in the new field.

None of this is working for me. Any other option?