Best answer

New subscription in Grow not triggering Zap to create/update Subscribers in Flodesk after test signup on website.

  • 23 March 2023
  • 8 replies
  • 69 views

I setup a zap with Mediavine’s Grow to add a subscriber to flowdesk. I ‘tested’ it with a subscriber it pulled from flodesk and it worked. But when I tried a test signup on my site it doesn’t work. I see the signup in Grow, but it doesn’t transfer the contact to Flodesk.

icon

Best answer by ken.a 28 March 2023, 16:08

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

It’s working now, Thank you so much!

Userlevel 7
Badge +6

Hey there @Thai Caliente,

I am jumping in here to see if I can help! Here’s what we can try to determine why the Zap is not working. Could you please try these steps for me?

  1. Turn off the Zap.
  2. Reconnect the app connection here: https://zapier.com/app/connections
  3. Publish the Zap.
  4. Trigger the Zap by creating a new subscription in Grow while the Zap is published.

Please give it a try and let us know how it goes?

Thanks! 😊

I did a live test on the grow form, and it shows a subscriber but does not send the subscriber to flodesk.

Userlevel 4
Badge +6

Hi @Thai Caliente 

I don’t see any problems with your setup. Can you please go to your trigger step and then load the most recent sample trigger by clicking the Load More button? After that, select the most recent sample and then test the Zap.

 

Here are screen shots of my setup:

 I’m not sure why the screen shots are not adding. Can I email them to you instead?

Userlevel 7
Badge +8

Hi @Thai Caliente -

Given that both of the proposed questions are true, can you please share some screenshots of your current set up so we can take a closer look at what might be wrong? Any details regarding your trigger and action are incredibly helpful in gaining insight in these situations, just be sure to remove any personal/identifying information. 

Admin permissions for Grow: Site Owner.  

Yes, I’m a Mediavine Publisher.

Userlevel 4
Badge +6

Hi @Thai Caliente 

I looked at our internal notes and found these two important things:

  1. Does the account need any special account permissions? Yes. Admin.
  2. Any there any other potential restrictions? Yes. Users currently need to also be Mediavine Publishers

Could you please confirm those two requirements? I’ll keep an eye out for your response!