Best answer

My new rows in Excel are not at the bottom of the table.

  • 31 October 2022
  • 7 replies
  • 112 views

Userlevel 1

Hello,

 

I am trying to create a zap that will automatically take information from a candidate’s profile in Tracker (the candidate tracking software I use) and send it to an activity in Tracker. 

The way I figured I could do this is by using Excel. I can automatically send data from Tracker to an Excel spreadsheet by using Link2Excel. I created a report within Tracker that has all the necessary information and linked it to a new Excel spreadsheet. When I click “Refresh Data” in Excel, it updates to the current information. 

So the Zap is really from the Excel spreadsheet to Tracker (and thus sending data back to Tracker that was originally in Tracker, but converting into an activity.)

The problem is this: when I update the spreadsheet, it does not add new rows to the bottom. It is updating all the data at once, and arranging them alphabetically.

Is there a way to set up the zap so that it recognizes a new row in excel that is not at the bottom? Is there another step I can add or a different way of doing this to fix the problem?

icon

Best answer by Troy Tessalone 31 October 2022, 22:43

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @fredkms 

Good question.

Try this Zap trigger: Excel - Updated Row

NOTE: If all the rows are being updated, then that could trigger a lot of Zap Runs and use a lot of Zap Tasks.

 

Userlevel 1

Hi Troy,

 

I am testing out the “Updated Row” trigger now. So far it looks like it only triggers if the information in a row is new, despite the fact that the entire spreadsheet is technically being replaced when I click “Refresh Data” in Excel. This should work for me.

Userlevel 7
Badge +8

Hi @fredkms !

Checking in to see if the Updated Row Trigger did the trick. I see you’re working with Scott in Support on this Zap also and he sent over some follow up questions to better diagnose!

Let us know how you’re getting on here!

Userlevel 1

Hi!

I turned off the zaps for “New Row” and started using “Update Row” instead. I “refreshed” the tables in Excel, and of the 30 total rows in the table, 7 new zaps ran. This seems like the right number, as there may have been changes to that many rows, but I will have to keep testing.

Also, I am simultaneously working with Tracker on this, but the “Resource” field seems to be strangely inconsistent. For example, it sometimes maps the field correctly, but is usually left blank on the Tracker side. It seems to always work for the resource that I used in my test zap, and is inconsistent with other zaps even when it’s the same resource used.

Userlevel 7
Badge +11

Hi @fredkms!

I wanted to check in to see if you’d managed to get all your issue resolved? I see some recent messages between you and our Support team. It seems like you’re good to go at the moment?

Userlevel 1

Yes, everything appears to working correctly!

Userlevel 7
Badge +11

Awesome news @fredkms! I’m happy to hear it :)