Question

Mapping Google Lead Form Questions to Action Fields in Zap


Userlevel 1

Hi, I’m trying to map the “Qualifying Questions” that I added to my Google Lead Forms, to my Zap/Google Spreadsheet, but the “Qualifying Questions” (and multiple choice) fields don’t appear in the Action Fields in the Zap, so I can’t assign them to the columns in my Google Spreadsheet.

 

Any help would be appreciated.


12 replies

Userlevel 1

Appreciate the assistance Troy, but my issue is that I can’t get the Lead Form to push its’ fields to the Zap.

I can’t see the option to add the multiple-choice questions in the Google Lead Form, into ANY of the Zap fields.

Eg: Question: What is your monthly budget? > Zap fields don’t see this question (or others)

 

Userlevel 7
Badge +6

Hi there @Sem Huray and @TheBishopAG,

I did some digging into this, and if you're finding that the sample data from Google Ads isn't aligning with the actual data from your Google Ads app, you might want to consider using a custom pill mapping workaround.

Don't worry if you're unsure how to do this - we have a comprehensive guide that walks you through the process. You can find it right here: 

Hopefully, this points you to the right direction! 😊

Userlevel 1

@Troy Tessalone, I am experiencing the same issue as mentioned above. I have set up a lead form in GoogleAds, but the value for Quality Questions is not picked up by Zapier.

 

The test is only available for a direct webhook, not if the connection is made through a connected account.

Userlevel 7
Badge +6

Hi friends,

I suggest contacting our Support Team regarding this issue so they can take a closer look at the Zap and its log and provide a solution since they have the correct tools for that, and my access is limited here.

You can reach our Support Team here: https://zapier.com/app/get-help

I appreciate your patience and understanding.

Userlevel 1

Same problem here. It’s a bug. I have done multiple tests and the DATA read by zap is the {{name of field}} and not the value; it’s not mapped well. and it’s from zappier side. Google send the good data and informations in the Data in, and the data out is really out 😂

Need zappier to confirm the bug. I need a fix on it.

Userlevel 1

Same problem here. It’s a bug. I have done multiple tests and the DATA read by zap is the {{name of field}} and not the value; it’s not mapped well. and it’s from zappier side. Google send the good data and informations in the Data in, and the data out is really out 😂

Need zappier to confirm the bug. I need a fix on it.

 

 

For informations of what happens in the ZAP history :

 

In the Data out of the Google trigger :
 

Google_question ?: Answer

 

and in the DATA IN of the Zoho part:

picklist::My_field: {{Google_question}}

 

what is expected in the DATA IN is :

 

picklist::My_field: Answer

 

it’s a bug, all the other informations in the DATA OUT of Google trigger are ok in the DATA IN of Zoho part, but not the google qualified question.

Hope it helps. need a fix.

Userlevel 7
Badge +6

Hi @Sem Huray,

If that’s the case, I suggest skipping the testing phase of the Zap by clicking on the "Skip test" buttons. Once you've done that, go ahead and publish the Zap. To ensure everything is working as expected, trigger the Zap with a test run. Afterward, take a look at the Zap History and see if the "Quality Questions" data shows up there. If it does, then you can proceed with the custom pill mapping workaround.

Please give that a try, and keep us posted! 😊

I am having the same issue as above. The qualifying questions do not show up in the ZAP History

I’m having an issue with this too. There’s no option for inserting the qualifying answers into the Zapier email we receive.

Userlevel 7
Badge +14

Hi @TheBishopAG 

Good question.

 

Help article: https://help.zapier.com/hc/en-us/articles/8496055479181-How-to-set-up-your-Google-Ads-New-Lead-Form-Entry-trigger#prerequisites-0-0

 

Make sure to test your GAds Lead Form, then pull thru the example in the Zap trigger: https://help.zapier.com/hc/en-us/articles/8496310366093

Userlevel 7
Badge +14

@TheBishopAG 

Did you test the Lead Form?

Did you then pull thru the test you submitted that had the custom questions answered in the trigger step?

https://developers.google.com/google-ads/webhook/docs/testing

 

 

Userlevel 1

Hi there @Sem Huray and @TheBishopAG,

I did some digging into this, and if you're finding that the sample data from Google Ads isn't aligning with the actual data from your Google Ads app, you might want to consider using a custom pill mapping workaround.

Don't worry if you're unsure how to do this - we have a comprehensive guide that walks you through the process. You can find it right here: 

Hopefully, this points you to the right direction! 😊

 

Using a custom pill would help to get the data from the received form data into the action data, but as the data from the Quality Questions field is not picked up from the Trigger Test, there is no way to scrape the “name of the field” from the Lead form entry.

I have asked ChatGPT for an answer, it said the custom question would be the “name of the field”, but it is not in the lead form entry data.

Reply