Question

Issue with Okta and Gmail integration: Missing fields in actual Run despite successful test.

  • 22 September 2023
  • 7 replies
  • 33 views

HI team,

 

I’d like to setup the Okta <> Gmail, the scenario is:

  • The Zapier will trigger the event from Okta (example: user deactivate)
  • And then create the email with information Okta. (example : deactivate the user Test.A)
  • I’d expect the Gmail can be include username which is Test A and the email address is test.a@domain.com
  • It is worked as magic on test step but when I running the Zapier and make another test. It is running to the gmail without needed fields. 

Can you please support me on that ?

Thank you !!!


7 replies

Userlevel 7
Badge +14

Hi @Tung Le 

Good question.

To help us have more context, please post detailed screenshots with how your Zap steps are configured.

Check your Zap Runs history details to see the DATA IN/OUT for each Zap step to help you troubleshoot.

Hi Troy,

 

Thanks for the reply. Please check on these screenshots:

 

As you can see, I’d like to send the email to team whenever we have deactivated/suspended users in Okta. 

And here the result I got from test step which is super good 

 

But when I running it reality, it return nothing

 

 

On Zap Run, Data In:

Data Out:

Thank you !!!

Userlevel 7
Badge +14

@Tung Le 

Check the DATA OUT from the Zap trigger step in the Zap Run.

Not sure if is this what you want to see? 

 

Userlevel 7
Badge +14

@Tung Le 

The issue may be that the sample data provided when configuring the Zap steps is different from the actual data provided when the Zap is ON and runs.

 

EXAMPLE

Data is nested like Target > Display Name

 

But in the actual DATA OUT from the Zap trigger step in the Zap Run, the values is nested like this:

Data > Events > Target > Display Name

 

You may have to go with an advanced approach to create custom {{variable}} pills.

 

You can try opening a ticket with Zapier Support: https://zapier.com/app/get-help

Userlevel 7
Badge +6

Hi @Tung Le,

It looks like our Support Team replied to your query yesterday with a suggestion of:

Thanks for reaching out for support with your Okta > Gmail Zap. I understand you've already sought advice from our Community but were recommended to open a ticket for more specialized assistance. I'm here to help!

However, I noticed that the email you've used to reach out isn't linked to the account where the Zap is set up. Unfortunately, I can't look into Zaps stored in a different account for privacy reasons. Could you kindly reach back out using the account that houses the Okta > Gmail Zap? Once you do, I'll be able to take a closer look and assist you more effectively. Don't hesitate to message here once that's done so we can go from there.

I'll keep an eye out for your reply and look forward to assisting you further.

I’d recommend continuing the conversation with our Support Team so that they can help you with your issue further.

Thanks!

Thank you @Troy, I will try to contact support.

Reply