Question

Intermittent trouble with delimiting line-items in CSV with Formatter.

  • 28 March 2023
  • 3 replies
  • 64 views

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

I’m having issues with some CSV files when using the Utilities in Formatter step in my Zap. Mostly this works, but for some files it seems to struggle with the Delimiting for the line items. 

 

Here’s a Zap that works fine, which shows the CSV input and Delimited fields with the ‘line_items’ ;

 

Here is a Zap that doesn’t work correctly with delimiting the ‘line_items’;

 

Does anyone have any suggestions on why this one may not be working ?

Many thanks,

Antony


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +11

Hey @antonyg! 👋

On the example run that didn’t work correctly, were there any nested line items in the file that was sent to that Formatter action? I’m just wondering whether that might have caused it to not read the line items as expected. Do you think that could be the case here? 

If not, could you please share some more details about where the information being added to the Formatter action is coming from? Any screenshots you can share showing the setup for the Zap’s trigger and actions would be greatly appreciated. We’re not able to look into your Zaps so that’ll help us to get some more context on what/how the data is being supplied so we can better help to figure out what the difference between those two runs of the Zap might have been. Don’t forget to remove/hide any private information like names, emails phone numbers etc from any screenshots first.

Looking forward to hearing from you!

Hi Sam, 

Thank you for the message. I have attached the CSV file in the first instance so that you can see if there is anything obvious here that is causing the issue. When I open using Excel using comma delimited, this works fine. 

If you can let me know your thoughts on this please, I can then share more details regarding the Zap with you. 

Many thanks

Antony

Userlevel 7
Badge +12

Hi @antonyg!

I deleted your csv as it contained personal and/or private information, please be careful when you’re sharing information in the Community as it is a public forum. If you would like someone to take a look at the file and your Zap more closely, you can contact the Support Team using the Get Help form.

 

As Sam suggested, my hunch is that for the csv that had trouble with the line items, there is a nested line item that’s confusing things. If you open the csv in Excel, do the line item fields look different to the line item fields for csvs that worked? For example, is there any additional punctuation in the fields?

 

I’m also curious that it looks like all of the values for the line item fields that didn’t work are ‘null’. Have you tried another csv where there are null values in the line items? 

 

​I hope that helps, please let us know if you have any questions!