Best answer

In Buffer posts scheduled 6 hours behind

  • 18 January 2023
  • 2 replies
  • 117 views

Userlevel 1
Badge

This post has been split from this question:

Hi @SamB, Sorry for the slew of messages. Just wanted to keep you in the loop. I have managed to get Monday.com to post to buffer. However, the schedule does not synch up properly. Every post is scheduled 6 hours behind for some reason. The minutes are correct. It's just the hours that are out. 

icon

Best answer by Danvers 19 January 2023, 13:45

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +12

​Hi @Laurence Hidson 

The most common reason for this type of issue is timezone settings. Here are some things to check:

  • The timezone setting of your Zapier account, which can be found in your profile settings
  • The timezone setting of the Zap, which you can find in the Zap details. You can get to that from the My Zaps page by clicking on the 3 dot menu next to the Zap, or in the Zap editor, using the right hand panel. 
  • The timezone setting on your Buffer account
  • The timezone setting on your Monday.com


A mismatch between these settings can cause your posts to be scheduled for the wrong time. 

If all of those settings are correct, the next thing to check is the Zap history. In a Zap run for your Zap, look at the data in and data out for the Buffer step. Is there a difference in the Scheduled time between the data in and data out? That means that Zapier is sending one time but receiving another. If so, try looking at the data that’s coming from Monday.com in the Zap trigger - is that the time that’s being sent to Buffer? In order to get the time back to where it needs to be, we need to identify which piece of the Zap is causing the trouble. 

Hope that helps!

Userlevel 1
Badge

It did, Changing the time zone setting on zappier immediately fixed my issue.

Thank you