Best answer

Having trouble posting from Instagram to YouTube

  • 26 August 2023
  • 17 replies
  • 124 views

Userlevel 1

I set up a zap with a trigger of posting media to Instagram and I want that media to be posted to YouTube. I believe I have the zap set up correctly but it is not posting to YouTube. Could that be because I manage two different YouTube accounts from one gmail address and it doesn't know which one to post to?

 

 

Here are some screenshots of my Youtube connections: (I did not choose "Rose Movement Youtube" because that is not the YouTube account I want to cross-post to)

 

Screenshot 2023-08-26 at 1.08.56 PM.pngScreenshot 2023-08-26 at 1.09.08 PM.png

icon

Best answer by Troy Tessalone 29 August 2023, 16:13

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

17 replies

Userlevel 1

It worked! Thank you

Userlevel 7
Badge +11

Ah I see! Thanks for clarifying that @Troy Tessalone and @aprilrosedance. I’ve passed this info over to the relevant teams here so that the documentation for the YouTube app can be improved. 🙂

Seems like you’re all set for now but please do reach out in the Community again if you need help with your Zaps in future, we’re always here and happy to help! 

Userlevel 7
Badge +11

Glad to hear the Zap works, @aprilrosedance! 🎉 

Did you make any specific changes to get it working? Or did it just start working correctly when it was switched on and had a new video posted on Instagram? I’m sure folks running into a similar issue would love to hear more about how you solved this! 🙂

Userlevel 7
Badge +14

@SamB 

When turning the Zap ON and testing the Zap action works for YouTube Upload Video.

I believe when you test the YouTube Upload Video Zap action in the Zap Editor, the step returns dummy data, and does not actually attempt to upload a video.

In the screenshots below you can see it returns what appears to be dummy data for the “Zapier” Channel.

I’ve seen quite a few people encounter this issue, because this behavior is not documented.

This should be noted in the YouTube help articles.

 

 

Userlevel 1

Yes, that was my experience, thank you!

Userlevel 7
Badge +14

Hi @aprilrosedance 

Good question.

Looks like some of the screenshots did not upload.

 

Userlevel 7
Badge +14

@aprilrosedance 

https://help.zapier.com/hc/en-us/articles/8495973053453-How-to-get-started-with-YouTube-on-Zapier

 

SoftTimeLimitExceeded Error

The process of downloading the video (from the origin), and uploading it to YouTube must finish within 180 seconds (three minutes). Otherwise, our system will cancel the process. We suggest compressing your video for it to be uploaded correctly.

 

I can't upload more than 5 videos in a day

If you're on a Free or Trial Zapier plan, you're limited to uploading up to 5 videos in a 24-hour period with the Youtube app. To fix held Zap runs, wait 24 hours, and you can replay them. To upload more than 5 videos in a day, you'll need to upgrade to a Zapier paid plan

Userlevel 1

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

PS: I tried connecting to the “Rose Movement” YouTube account to see if the action test would work with that account but when I tested the action it did not share the media to YouTube.

Userlevel 1

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

I am the account owner. Can you please explain more about the screenshot and article you shared? I’m not sure what to do with that info. Thank you. 

 

Userlevel 7
Badge +14

@aprilrosedance 

Is this a public direct download link?

You can test by copy/paste into a browser to see if it starts a download of the file immediately.

 

Userlevel 1

I can’t figure out how to copy/paste the link. It worked to cross post to facebook in this zap, just not YouTube

Userlevel 7
Badge +14

@aprilrosedance 

When you test the YouTube step, do you encounter an error?

If yes, then post the screenshot of the error.

Userlevel 1

No error when I test

Userlevel 7
Badge +14

@aprilrosedance 

Can you post a screenshot of the returned data after testing the Zap step?

Userlevel 1

 

Userlevel 7
Badge +14

@aprilrosedance 

Can you post screenshots of the other fields seen by scrolling down?

 

Userlevel 7
Badge +14

@aprilrosedance 

Something to try…

Turn the Zap ON and test live.