Best answer

Gmail with a specific label triggering a Slack Alert - works in test, never after, any ideas?

  • 21 October 2022
  • 4 replies
  • 52 views

Here’s the Zap itself - I have repeatedly tried and retried, but with no luck.

 

The trigger i have set up is the Label “Trigger” - that’s done correctly

Then this is intended to be a sort of form to fill out, so i have a numbered list

then i send the email, and nothing works

 

Any thoughts?

 

https://zapier.com/shared/gmail-to-slack/b6da3df19d798e50c98c2c5238f7f5a142e14fde

icon

Best answer by shalgrim 22 October 2022, 22:27

View original

4 replies

Userlevel 6
Badge +8

Hi @robertjfinn,

Happy to try to help!

It looks like you had two successful runs for this Zap a short while before you submitted this post. Is it maybe working now?

You’ll have to label the email with the label you chose in the trigger before the Zap will run. Once you do that it will send the slack message into the channel you designated in that step.

Does that help? Let me know if I’ve misunderstood what’s not working

hi there - thanks for getting back to me

 

i’ve sent about 10 emails, and i was under the impression that the only ones that have worked thus far were the tests

 

i just sent 2 more, no luck.

 

if its set up properly, it should fire no matter what whenever i use the label correct?

Userlevel 6
Badge +8

Hey Robert,

It looks like we had a few more successes since I last checked in. Not 10, but has it been more than just the testing you’ve done in the editor? Have you gotten to work at all in the wild?

Your message from yesterday says you “just sent 2 more” with no luck. Have those two come through since then?

it should fire no matter what whenever i use the label correct

 

That’s correct. When you add the label to an email, that should trigger the New Labeled Email trigger you’re using, but I need to add one more piece of information to that. This is a polling trigger, which means that the Zap won’t trigger instantly. Polling triggers run on a schedule that is determined by your plan. You can read more about polling intervals here and if you scroll down on this page, you can see the different polling intervals for different plans, including the one you’re on.

All of which is to say, yes, when you add the label, the Zap should trigger within the next X minutes, where X minutes is your polling interval.

There’s one more trick here. If you don’t want to wait around for the X minutes to see if your test is going to work (and I don’t blame you), we have a Run button for polling Zaps where you can manually poll for all new labelled emails. Here is a picture that demonstrates how to manually run a Zap.

So, I hope that clarifies everything, but even more I hope your Zap is working as expected. If not, definitely let us know and we’ll dig in and see if we can’t figure it out for you!

Best,

Scott

Userlevel 7
Badge +12

Hi @robertjfinn!

Did you manage to get your Zap up and running with Scott’s suggestions? Lest us know if you still need some help here!

Reply