Best answer

Gmail sent emails are limited to 78 characters per line

  • 17 September 2020
  • 7 replies
  • 3063 views

Userlevel 3
Badge

Hello zappers,

I’m having an issue with email formatting. It seems to be restricting the email to 68-70 characters per line… but only for the receiver. The formatting in the Sent box looks normal.


Sent box (show it ought to look):

 

Inbox of recipient (I don’t want it to look this way):


Here is what it looks like in Zapier:



What is going on and how can I fix it? Thanks!​

icon

Best answer by kenyon 19 September 2020, 12:57

View original

7 replies

Userlevel 2

Hey @briansballoons, Kenyon here from Zapier!

It turns out this is expected behavior. Google reformats plain text emails sent through Gmail so that the messages adhere to RFC 2822's limit of 78 characters per line. If you'd like to avoid that, I'd suggest using the HTML option when configuring your email.

Apologies for the confusion! 

You can fix it using HTML tag.

 

Example:

<html>

<p>….</p>

<h1>….</h1>

<a href=”….”>….</a>

</html>

Userlevel 7
Badge +10

Hi @briansballoons 

I’ve had a simiar issue with my zaps, so I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +12

Hi @briansballoons! I’m sorry that the formatting of the emails doesn’t look right!

The first thing to check is the format of the text in the ‘body’ field of the Zap.

 

If you copied and pasted the message in the body from somewhere else, the some of the formatting from that might be being carried over. To make sure that isn’t the case, please could you remove the text that is currently in the field and then paste it again as plain text. To do that, right click your mouse and press Ctrl+Shift+V (or cmd+Shift+V on a mac). If that doesn’t fix the issue, please could you get in touch with our support team via the Get Help form so that they can take a closer look at your Zap. Thank you!

Userlevel 2

@Danvers I’ve had a similar issue myself. Would adding HTML formatting (body type: HTML vs “plain”) also solve this?

Userlevel 3
Badge

Hi @Danvers,

I tried pasting as plain text, but to no avail - the formatting is still messed up.

I was copying it from a gmail template, and another thing it does when I initially paste it into zapier is remove the space between words every 78 characters or so. I added the spaces back, but the newline stuff is still there for the recipient.

My boss has instructed me not to spend much more time on this because he doesn’t mind the formatting. But if anyone has a solution or if zapier can fix it that would be great.

Userlevel 3
Badge

@kenyon Ahh okay I see - thanks!

Reply