Best answer

Failed to schedule a delay: Dates cannot be more than a month in the future.

  • 11 January 2024
  • 3 replies
  • 57 views

Userlevel 1

 

I am trying to delay a text message to send 4 hours before an event begins. I’m using a formatter with the expression -4 hours and then inputting that time into the delay action.

 

Currently with this setup 2 things will happen: 1. The text message is received right as a ticket is purchased. or 2. Get an error message “ Dates cannot be more than a month in the furture “ ← even if the event is set for this week.

 

Looking to set this text message to be delayed correctly 

 

Apps being connected: Eventbrite and Twilio

 

 

icon

Best answer by Troy Tessalone 11 January 2024, 16:08

View original

3 replies

Userlevel 7
Badge +14

Hi @Gemz 

Try changing the expression to: -4h

Make sure to check the field description (more) for guidance.

 

Userlevel 1

Hi, Adding in the expression correctly did fix the formatter issue however I’m still seeing this error message “ 

Failed to schedule a delay

Error from halted execution: Date is more than 60 minutes in the past “  

 

 

 

Userlevel 7
Badge +14

@Gemz

I Need to Delay a Step Longer Than 1 Month

You can delay an action for no more than 31 days.
Combining Delay steps to increase that maximum may error and isn’t recommended.
Use Google Calendar’s Event Start trigger to create delays for longer than 31 days.

 

The timestamp provided was more than 60 minutes in the past, when the Zap run step happened.

You may need to adjust the Delay step settings to handle for this use case.

 

 

Reply