Question

Error: Failed to create a custom object in Salesforce, status code 400 Bad request

  • 2 November 2022
  • 3 replies
  • 505 views

Userlevel 1

Hi, I'm trying to connect my TikTok leads to a Salesforce Custom object through Zapier, but I get the following errors. 

 

Failed to create a custom object in Salesforce (Legacy)

We're getting an error for the field (insert field here, if possible). This usually happens when the value we're using in the "Custom value" isn't being accepted by Salesforce. In most cases, we want to map an ID field there, instead of what is mapped there now.

 

Status Code 400 Bad Request

Last updated: 3 years ago

Problem

Your Zap is likely to be missing a required field, or a field value wasn't in a recognized format. For example, if a field in your action step is expecting an email address, but the value given is a name, the app may return a 400 error.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 5
Badge +7

@Bobo hows it coming along over there? Were you able to switch over to the current Salesforce integration? Let us know either way, and we’re happy to keep helping you along. 

 

Best,
Rachael

Userlevel 1
This is the only field where I think the problem might be, but I have no available options 

 

Userlevel 7
Badge +8

Hi @Bobo 

 

It seems you are using Salesforce old integration, this is why it says Salesforce (Legacy). Use the most recent integration instead. (You probably had an older zap that used the Legacy action)