Cannot remove "Zapier for Gmail" add-on

  • 8 January 2024
  • 3 replies

Userlevel 1

Zapier for Gmail add-on cannot be removed.


When selecting 3 dots → manage add-on → pop-up gets stuck loading


When trying to remove via settings / add-ons → settings menu shows Zapier add-on but marketplace shows no add-ons (see attached image)


How to fix?


3 replies

Userlevel 7
Badge +14

Hi @MilesB 

Related topics to reference:

Userlevel 1

Thanks for your reply. I already read through this thread and tried the proposed solutions, but none worked for me. I have also submitted a support ticket to Google.


It seems that this issue has to do with the version of the add-on being deprecated/removed from marketplace by Zapier.


I cannot find it on the marketplace, so it seems the version of the add-on I have is an artifact which prevents it from being removed.


Any other suggestions or help is greatly appreciated! Thanks

Userlevel 7
Badge +6

HI there @MilesB,

I’m jumping in to see if I can help.

I understand you're having trouble trying to remove the Zapier add-on from Gmail. Here are a few alternative ways to remove the add-on:

  1. Remove from G Suite Marketplace: Visit the G Suite Marketplace and find the Zapier add-on. Click on it, and you should see a green "Installed" button. Click on the three vertical dots next to the button and select "Uninstall."
  2. Remove from Google Account permissions: Visit the following link to manage permissions for third-party apps connected to your Google Account:
  3. Locate the Zapier add-on and click on it. Press the "Remove Access" button and confirm the action to revoke access and uninstall the add-on. Please make sure you're signed in to the correct Google Account when performing these steps, since the add-on may be installed on a different account. 

Alternatively, you can try these troubleshooting methods to resolve the infinite loading issue when managing add-ons in Gmail:

  1. Clear browser cache and cookies: Clear your web browser's cache and cookies to ensure any outdated data or temporary files aren't causing the issue.
  2. Try a different web browser: Attempt to manage the add-on using another web browser (e.g., Chrome, Firefox, Safari, Edge) to determine whether the issue is browser-specific or affects multiple browsers.
  3. Disable browser extensions: Some browser extensions may interfere with Gmail and its add-ons. Disable any browser extensions you're using, particularly those that interact with Gmail or modify its appearance, and reload Gmail to check if the issue persists.
  4. Check for browser updates: Confirm that your web browser is up-to-date, as outdated browser versions may not support recent Gmail features. Update your browser if necessary.

If the steps above did not work. I’d recommend reaching out to Google Support  to see if they are able to remove it.